[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X crashes when closing one of two running X sessions

On Thu 19 Oct 2017 at 08:35:55 (-0700), Jimmy Johnson wrote:
> On 10/18/2017 09:13 AM, Robert Arkiletian wrote:
> >Using Debian Stretch x86_64. I don't use a greeter like lightdm. I
> >just log in at the virtual terminal, then startx (xfce desktop). I
> >like to use multiple accounts (running X) at the same time on
> >different virtual terminals (eg. ctrl-alt-f1  ctrl-alt-f2)
> >
> >All is fine until I exit (shutdown) one X session, then the other
> >running X session freezes and then after a little while crashes. Any
> >ideas on how to find or diagnose what's causing this issue are much
> >appreciated.
> I don't know about how you shutdown a terminal, me I just ctrl+d and
> it logs out.

That sounds like you're talking about an xterm, not X.

Anyway, my suspicion is that perhaps there's a problem in restoring
the mode for the console that X started from, when it terminates. I've
had that problem in the past on this Acer laptop (on every
termination) though upgrades have often fixed it.

Currently, I have no problem if I haven't worked the system too hard
(which is tricky in 500MB memory), but after doing much browsing
(which tends to thrash the 1GB swap), terminating X will leave the
machine with a black screen. It's still running (I can ssh into it)
but about the only thing that works is the power button, whereupon
after a few seconds the normal VC screen appears with the closedown
messages scrolling by. (The only untested feature is whether the WiFi
kill switch (external) still works.)

I can avoid the black screen by, instead of using Ctrl-Alt-Backspace
to exit X, typing Ctrl-Alt-F2 for a VC and then killing X with
pkill xinit. VC2 now remains usable, just so long as I don't
accidently move to VC1, which puts it into its black screen state.

This Acer has a Radeon driver that is peculiar. When I boot, it's
important that I see these messages:
[   12.195543] radeon 0000:01:00.0: firmware: failed to load radeon/R300_cp.bin (-2)
[   12.195605] radeon 0000:01:00.0: Direct firmware load failed with error -2
[   12.195608] radeon 0000:01:00.0: Falling back to user helper
Were it to load that firmware (which I've hidden), it would crash
after just a few seconds.

Perhaps a workaround for you would be to only use "real" VCs when the
system is freshly booted, and then start a DM so that you stay inside
your X sessions evermore, until the next reboot; ie a one-way ticket.


Reply to: