[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: (solved) Can't find the DNS Servers

On 10/05/2017 10:30 AM, Brian wrote:
On Thu 05 Oct 2017 at 10:00:01 -0700, Gary Roach wrote:

On 10/04/2017 01:44 PM, Reco wrote:

The contents of /etc/nsswitch.conf, please.
The current contents of /etc/resolv.conf.

The output of (terminate it with Ctrl+C after 60 seconds):

tcpdump -nvi any udp port 53 or tcp port 53 or udp port 5353

While doing:

getent hosts go.dev


Hooray, Solved.
Rico, your question about nsswitch.conf was the key. I printed out the file
from another computer and found that the "hosts:" line was missing "dns and
mdns4'. I added these to the end of the line and everything now works fine.
I can't thank all of you enough for your support.

I could be wrong but I think you mean "mdns4_minimal [NOTFOUND=return]"
was missing.

No. The particular line reads:
"hosts:  files mdns4_minimal [NOTFOUND=return] dns mdns4"
It works!

Didn't mean to slight anyone with the thanks. I know that this was somewhat of a community effort. So thanks to all.

Gary R

Reply to: