[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't find the DNS Servers


On Sun, Oct 01, 2017 at 07:26:30PM -0700, Gary Roach wrote:
> This is the second time I've tried to send this. The first one just
> disappeared to the bit bucket I assume. So lets try again.

It did not. Everyone on the list got it, I believe.

> Sorry about the delay in replying to your request. Attached is the
> information you requested. I could not find nameservers and
> listed anywhere. This is probably the root of my problem.

No, your problem is different.

> I tried every
> thing I could think of but couldn't get them to stick in resolv.conf.

So, let's get this party started.

First, you have "eth0" defined in your /etc/network/interfaces.
A simple DHCP configuration that *can*, but *does not* honor your
"dns-nameserver" stanzas.
The reason being - you put them *after* br1 interface.

Second, you have "br1" bridge that:

1) Tries to bridge itself. Nothing good will ever come out of this.

2) Does not try to bridge eth0. I don't know, it may be intended.

3) Does not have *auto* keyword defined, so this bridge does not come
into play.

Third, and that's no wonder, you have so-called Predictable NIC Names
configured, so your *actual* interface is called enp4s0, not eth0.
Therefore e/n/i does not apply to it, something else was used to
configure it.

Fourth, you have your virbr0 interface presumably configured by libvirt.
Which means that it's configured at
/etc/libvirt/qemu/networks/default.xml or maybe some other file at

Routing table does not contain anything unusual, as does

To bring order to this chaos, you'll need this e/n/i:

auto enp4s0
iface enp4s0 inet dhcp

Please note the indentation, and that I deliberately omitted "br1". You
don't need it anyway, you have libvirt to take care of bridging.

What you also need is:

1) resolvconf package. dns-nameserver stanzas are ignored unless you
install it.

2) Any kind of dhcp client. A stock isc-dhcp-client should do it.

3) Deinstalling (disabling) whatever you're using now to configure
enp4s0 now.

4) libvirt-doc package. After you restore your primary network
connectivity, please point your browser to
/usr/share/doc/libvirt-doc/formatnetwork.html .


Reply to: