[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: (solved) Can't find the DNS Servers

On Thu 05 Oct 2017 at 11:38:20 -0700, Gary Roach wrote:

> On 10/05/2017 10:30 AM, Brian wrote:
> >On Thu 05 Oct 2017 at 10:00:01 -0700, Gary Roach wrote:
> >
> >>Hooray, Solved.
> >>Rico, your question about nsswitch.conf was the key. I printed out the file
> >>from another computer and found that the "hosts:" line was missing "dns and
> >>mdns4'. I added these to the end of the line and everything now works fine.
> >>I can't thank all of you enough for your support.
> >
> >I could be wrong but I think you mean "mdns4_minimal [NOTFOUND=return]"
> >was missing.
> >
> No. The particular line reads:
> "hosts:  files mdns4_minimal [NOTFOUND=return] dns mdns4"
> It works!

So the line went from "hosts: files mdns4_minimal [NOTFOUND=return]" (no
dns!) to "hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4", The
stock Debian line is "hosts: files mdns4_minimal [NOTFOUND=return] dns"
"mdns4" is not on the line because of #433943.

 Please drop the final "mdns4" from the default nsswitch.conf line. While
 it is quite useful to enable proper reverse lookups on non-link-local
 addresses it also has the big drawback that if there is neither avahi
 nor classic dns set up for an IP address this module has to timeout
 before the reverse lookup can fail. This becomes a problem because many
 programs freeze during these lookups, one being ssh on every single
 incoming connection.


Reply to: