[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pesky and persistent "driverless" Brother MFC-9340CDW

On 08/04/2017 06:37 AM, Brian wrote:
On Thu 03 Aug 2017 at 21:39:43 -0400, Jape Person wrote:

A few weeks ago a CUPS upgrade to our Debian testing systems
started showing a new driver for our Brother MFC-9340CDW in print
dialogs and in the CUPS printer list and in the
system-config-printer utility.

You'd think that was good news, but we've been unable to find any
way to make the queue for this "driverless" instance of the printer
function properly.

It *is* good news. The printer was set up automatically, something people have been asking for for years. No non-free drives, either. A
pity about the printout. That shouldn't happen, The cause would need
to be looked at. Maybe the printer is non-conforming to IPP Everywhere.

Well, it *would* be good news if it actually produced usable output. As things stand right now, it's merely a way to waste time, paper, and toner.

I'll admit I was tickled when I saw that there was a driver specifically for this printer, and then not tickled when it didn't work but wouldn't go away.

The only way we can print with this printer is to do what we were
doing before the new "driverless" instance of the printer showed
up. We add a printer to the system via system-config-printer or the
CUPS Web browser dialog and deliberately select the Brother
MFC-9320CW Foomatic or Brother Script-3 driver. (That's not a typo.
I'm deliberately choosing a different model.) Both of those PPDs
work. I have to provide a deliberately altered name for this
instance so users can tell it from the one that doesn't work.

Brother provides software for this printer.

http://support.brother.com/g/b/downloadlist.aspx?c=gb&lang=en \ &prod=mfc9340cdw_all \ &_ga=2.149781630.955111390.1501838613-23812213.1497304959&os=128

(URL line broken for readability).

When I first got the printer I updated its firmware. This isn't as easy as you might think. You have to have a Windows or Mac computer to perform the update, and I didn't own one. I purchased a little Windows 10 gizmo from SimplyNUC so that I could do this update, and so that I could perform firmware updates on a couple of GPS devices.

I also tried the proprietary software, just for grins. I never intended to use anything other than what's in the official repos on my Debian systems. The helter-skelter way the driver installation directions were written and the absolutely hilarious hodge-podge of license notices and balky scripts was kind of horrifying. But I'll admit that everything worked, once I weeded out the inappropriate directions and fixed the installation. And I appreciated that all was installed in a manner that made it easy to remove.

The functionality of the proprietary printer driver was no better than that of the MFC-9320CW driver from CUPS, other than it included the ability to monitor toner levels. But all of that sort of stuff is readily available via the Web interface of the printer.

Since I have workaround, I can't bring myself to re-install the proprietary driver. I do have to use the Web interface to see the maintenance information, and I have to get scans via my wife's Android tablet. But I just found the proprietary drivers to be icky.

The particularly annoying thing about this situation is that I
cannot delete the "driverless" instance of the printer from CUPS /
system-config-printer. The instant it is deleted, it is
automatically re-detected and added back to the printer list. But
anyone who chooses to print to it is going to get a distorted or
garbled printout.

I was able to set a policy in the instance so that only root can
print to it, so a regular user isn't going to waste time and paper.
Still, it would be nicer if I could turn off the advertisement that
the printer and the operating system is providing for the
"driverless" instance.

"CreateIPPPrinterQueues No" in cups-browsed.conf. Or switch off
Bonjour broadcasting (AirPrint) on the printer.

Hmmm. I turned off AirPrint through the Web interface right from the beginning. I just checked it again, and the interface indicates that AirPrint is turned off.

I'll go further down this path if other tactics don't work.

Thank you so much for your time and effort. I didn't think of looking in cups-browsed.conf because I thought turning off AirPrint should have done the job.

Reply to: