[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Sudden death of bluetooth headphone connectivity

On Thu, Aug 03, 2017 at 08:25:27PM +0100, dekkzz78@gmail.com wrote:
> Mark,
> What BT chipset are you using, have you acccidently disabled it in BIOS?
> Nothing shows up in google about protocol not available but there was a bug
> in gnome 3.24 and pulseaudio 10 with gnome/GDM where GDM starts its own
> pulseaudio instance.
> https://wiki.archlinux.org/index.php/Bluetooth_headset#Gnome_with_GDM
> I don't run gnome on debian but i do on arch, i didn't find the gnome BT
> stack particularily stable so i used blueman-applet as a backup in the cases
> gnome BT wouldn't work with my FSL360. see blueman & bluez-utils packages in
> stretch.
> Blueman-applet allows you see if the device is trusted & paired and to
> perform those functions if you wish. It also identifies the BT adapter in
> use which should appear in lsusb.
> If that's no further help look up the Arch wiki section on bluetoothctl
> [from bluez-utils]. 99% of the time the issues i had were BT getting
> confused about adapters.

Some more info I just discovered.

First of all, it's not just a2dp-sink protocol that is reported missing. 
I just tried to connect my iPhone which I set up back in the Jessie days 
as an a2dp SOURCE so I could play music from it through my PC speakers, 
and got the same behaviour and an error in the systemd journal saying 
a2dp-source not available. IE same error but source instead of sink. To 
me, this implies the problem is not specific to a2dp-sink protocol.

Now the variable here is that it was way more of a fiddle than I 
expected it to be to get playing music from my iPhone through the 
computer's speakers to work in the first place, years ago, and I haven't 
tried since the upgrade from Jessie->Stretch, so THIS PARTICULAR task 
could have been broken since the upgrade and I wouldn't have known. It's 
far more important to me to get my headphones working again than it is 
to get the iPhone able to play music through the computer's speakers.

To your point about the bluetooth potentially being disabled, I don't 
think so because: A) the bluetooth hardware on this circa-2009 
self-built Core i7-920-based PC with an ASUS P6T motherboard is a USB 
bluetooth dongle about which the BIOS knows nothing, and B) I tried the 
only bluetooth operation I could think of that didn't involve audio, 
trying to connect to my iPhone as a network provider, and while the 
connection failed it did so at the stage of the computer asking it for 
an IP address, NOT at the stage of trying to connect via bluetooth. In 
fact I can clearly see it report success connecting to the phone in the 
log, followed by a series of error messages relating to DHCP, and then 
the connection gets dropped. In terms of visual effect, in this case the 
slider button stays in the ON position for several seconds before going 
back to OFF, in contrast to the audio-based bluetooth attempts which 
fail instantly.

The phone isn't set up to provide a network, so it is no surprise to me 
that that operation failed, but the point is it DIDN'T fail at the 
bluetooth stage.

I guess the next thing to try is your blueman suggestions. It strikes me 
as odd that it would be working fine and then suddenly break though.

I had always thought that blueman IS the Gnome bluetooth applet -- 
guess that was my misunderstanding.

By the way, I failed to mention in my original post, but in case anyone 
is wondering the audio on my PC is basically working fine, if I watch a 
video or something on the computer using the computer speakers, the 
audio is fine. So pulse, audio config on my PC, permissions etc, all are 
demonstrated OK. No problems until I bring the bluetooth devices into it.


Reply to: