[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Thinkpad function keys in Stretch


After update to Debian Stretch, I'm having problem with function keys on
T440s. On Jessie, everything worked out of the box, but now volume up
and down, screen brightness and mic mute don't work. Sound mute work,
but only partialy. Led indicator doesn't turns on and it just mute the
sound, it doesn't toggle it, like before. 

$ cat /proc/acpi/ibm/volume 
level:          unsupported
mute:           off

thinkpad_acpi is loaded. 

lsmod |grep thinkpad
thinkpad_acpi          86016  1
nvram                  16384  1 thinkpad_acpi
snd                    86016  15 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_timer,thinkpad_acpi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek,snd_pcm
rfkill                 24576  7 bluetooth,thinkpad_acpi,cfg80211
video                  40960  2 thinkpad_acpi,i915

Here is dmesg:

dmesg | grep thinkpad 
[   10.656995] thinkpad_acpi: ThinkPad ACPI Extras v0.25
[   10.656996] thinkpad_acpi: http://ibm-acpi.sf.net/
[   10.656997] thinkpad_acpi: ThinkPad BIOS GJET82WW (2.32 ), EC unknown
[   10.656997] thinkpad_acpi: Lenovo ThinkPad T440s, model 20ARS08L01
[   10.657606] thinkpad_acpi: radio switch found; radios are enabled
[   10.657708] thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness control, supported by the ACPI video driver
[   10.657709] thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
[   10.659307] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[   10.660120] thinkpad_acpi: rfkill switch tpacpi_wwan_sw: radio is unblocked
[   10.665657] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input8

So, it seams that thinkpad_acpi disables the brightnes control.

xbacklight doesn't work either. 

$ xbacklight -get
No outputs have backlight property

$ ls /sys/class/backlight/intel_backlight/
actual_brightness  bl_power  brightness  device  max_brightness  power subsystem  type  uevent

I tried various kernel options:

acpi_osi="!Windows\ 2012"

in all combinations, without success. 

I also tried linux-image-4.11.0-0.bpo.1-amd64 kernel, but still no joy. 

Tried old kernel, 3.16.0-4, too, but this time it didn't work either.

I'm using 4.9.0-3 at the moment.

Any idea what could be wrong?


Reply to: