[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

What On Earth Did I do? (was Boot Drives for older Systems)

	This story has a good ending but I am mystified.

	Until the new boot drives I ordered get here, I took an
old slow 10GB Maxtor drive and made a new installation of Debian
jessie and got it like I wanted it. It booted fine on the older
Dell system whose drive went to the ultimate bit bucket so I
decided to save the image via dd so as to dd it to other boot drives.

dd if=/dev/sdb of=systemname.bin

	The image copied slowly but did appear to copy so I put
the drive that had been copied back in to the system being
repaired and booted up again.  There was that sickening beep-beep
one hears when the game is over before it starts.  I checked the
jumper and it was okay for being the master boot drive.

	I tried it on a known good system and no luck there. Did
I accidentally reverse the if and of names?  No because had I
does so, the target would have been trashed. It is also 7 times
bigger than the source so it would have been a bust all round and
the system I had used for the copy was still up and running when
all was done.  I could mount the drive I had copied and read it.
Fdisk showed all the partitions were still there so I decided to
check the boot flag. It obviously had been working at first but
could have gotten modified.

	/dev/sda1 is the primary partition with sd5 being swap
off of sd2 which is an extended partition. fdisk told me that the
boot flag defaults to sda5 so I told it to set the flag and
re-wrote the table. A re-running of fdisk confirmed that the *
was now on sda5 so it was time to try to boot again.

	It boots again on the old system.  The only event between
the last time it worked and now was the total dd copy.

	Any better suggestions as to how the boot flag got
changed are quite welcome. This probably means that the boot flag
in the copy I made is also corrupt and will need to be set when
applied to a new disk. I have used dd many times and never had it
write any changes to the input so I am confused.

	Thanks and so far, it is back like it was.

Martin McCormick

Reply to: