[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: command not found [SOLVED]

On Wed, Dec 16, 2015 at 07:18:31PM +0000, Brian wrote:
> On Wed 16 Dec 2015 at 11:05:22 -0700, Bob Holtzman wrote:
> > On Wed, Dec 16, 2015 at 12:06:14AM -0500, Bob Bernstein wrote:
> > > Please post your .fetchmailrc, obfuscating any identifying
> > > information in it.
> > > 
> > > Scripts can yield up a "command not found" when the nfg executable
> > > is not the script itself but, say, some utility called in the
> > > script. (Think: "Do I need to make any egreps greps." Just an
> > > _example_.)
> > > 
> > > Also, run 'fetchmail --version' for debugging info.
> > 
> > It was disabled in the /etc/default/fetchmail file.
> What do you mean by "it"? Do you mean you changed
> to
>   START_DAEMON=yes ?
> What would that have to do with running the command "fetchmail"? Either
> fetchmail fetches mail from a POP3 server or it doesn't. Running it as a
> daemon would appear to me to have little to do with it, especially as
> your first post did not mention this was requirement.
> I have "START_DAEMON=no" and the fetchmail command does what it is
> supposed to do.
> You need to examine what your requirements are and how you have gone
> about implementing them.

Ran a search on "command not found" and one of the hits talked about
changing the /etc/default/fetchmail file from "START_DAEMON=no" to 
"START_DAEMON=yes". I tried it and fetchmail immediately started
working. After reading your post I tried changing it back to "no" and,
I'll be damned, it still works.

My requirements are simple and evident: I want to d/l my email. My
implementation is the same that has for many years, including yesterday
(after the fetchmail command started working).

I've been running linux in various distros for over 10 yrs and every
once in a while something like this pops up to show me how little I
really know. One thing about linux, sometimes it's a great little ego

Reply to: