[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Gnome Audio Alerts

Jose Martinez <jomartinez812@gmail.com> writes:
> On Sat, 2015-09-05 at 02:42 -0400, Ric Moore wrote:
> Thank you for your response, Ric.  I hadn't tried alsamixer. In fact,
> I've never pulled the alsa mixer up since install, I'm using PulseAudio,
> and so have used the PulseAudio controls.  In any event, I'm not sure
> what I should see with the alsa mixer, but I only have a master playback
> control, which is at 100% and a capture control, also set for 100%.
> There are no other controls available on the alsamixer.  I'm almost to
> the point of completely un-installing gnome, and then re-installing
> gnome from scratch (if that is even possible) to see if I can get them
> back.  I play music and other audio all the time, but I also use the
> audio notifications, especially for email, and hate it when they are
> out.

	You should have a few more sound controlls and they
usually have less granularity than 1/100TH. Some have 16 or 32
discrete levels and you can set them to X% but that X% rounds up
or down to the nearest setting. If your card shows 0 to 31 level
settings, amixer will, for example, set the level to 8 if you ask
for 50%. If you ask for 51%, it will still probably set the level
to 8 because there isn't a discrete level in the hardware that
neatly correspond to 51%.

	In many cases, this isn't that bad since your ears can
normally not detect changes up or down of much less than 3 DB.
What you are actually dealing with is the driver's interpretation
of what the hardware for your sound interface will allow you to do.

	I had something somewhat similar happen earlier this year
when I stopped using pulseaudio due to several weird behaviors of
sound which, on this older Dell system, is always itching to
break any time I upgrade Debian. After upgrading from squeeze to
wheezy, the CS4236 on-board sound chip disappeared so
$ aplay -l
produced only external sound cards such as usb cards or a SBLive
card as Card 0.

	After turning off pulseaudio, amixer for Card 0 produced
an output something like the one you described.
aplay -l showed no Card 0 and 1 Card 1.  amixer for Card 1 showed
all the bells and whistles that should have been there and they
worked. Playing something using Card 0 would play the audio file
but all the controls but playback and possibly capture were gone
and playback had that fake 0-100 range of granularity.

	This, by the way, was all under the command-line, no
gnome so when the system gets confused about sound hardware and
the drivers being used, the problems show up in all kinds of odd
or missing behavior.

	On this system, I guess the CS4236 is a goner for
anything above squeeze which is a pain because that on-board
sound system used inputs from the PC speaker beeper and could
send outputs from the analog sound card to the little speaker
making it possible to send analog sound to that device if one
needed to.


Reply to: