[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sound stopped working after upgrade

Le septidi 17 thermidor, an CCXXIII, Bruno Schneider a écrit :
> I can see my card in /proc/asound/cards:


> But I can't play sound on it:

The reason is in the error message. Unlike some other systems, Linux gives
useful error messages, reading them is a good habit to take.

> aplay: set_params:1239: Channels count non available
Like many modern sound controllers, your does not like mono.

> AFAIK, I shoudn't be able to play anything on ALSA if pulseaudio is
> using it. So I stopped pulseaudio but got the same error msg.

You did well, since the very first step of the advice I gave was indeed to
get rid of pulse-“make my problems impossible to debug”-audio.

> Thinking that 16kHz mono, is probably not the best choice for aplay, I
> made a 44100 Hz stereo wav file.


> Then aplay gives me no error and is apparently playing the file, but there
> is no sound. Running alsamixer, nothing seems to be muted. I have full
> volume bars on Master, Speaker and PCM. I have green 00 on Master and
> Speaker. Auto-mute is disabled.

You could try posting the output of amixer (with the correct -D option for
your card), someone may spot something not correctly routed.

I assume, of course, that you re-re-checked the speakers and tried to plug
them in all sockets?


  Nicolas George

Attachment: signature.asc
Description: Digital signature

Reply to: