[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

sound stopped working after upgrade

I run Debian Wheezy.  About a month ago I updated some of my packages
and sound stopped working in all of my programs.  I completely forget
the exact commands I ran or packages I upgraded.  At the time I didn't
care that sounds didn't work, but now I want to get it working again.

I *think* the fundamental problem is that /dev/dsp doesn't exist.  For
example, when I run mplayer, I get the following output:
$ mplayer allen_arrogh.wav
MPlayer 1.1-4.7 (C) 2000-2012 MPlayer Team

Playing allen_arrogh.wav.
libavformat version 54.6.100 (internal)
Audio only file format detected.
Load subtitles in ./
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 11025 Hz, 1 ch, u8, 88.2 kbit/100.00% (ratio: 11025->11025)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file
or directory
DVB card number must be between 1 and 4
AO: [null] 11025Hz 1ch u8 (1 bytes per sample)
Video: no video
Starting playback...
A:   0.8 (00.8) of 0.9 (00.8)  0.2%
Audio output truncated at end.
A:   0.9 (00.8) of 0.9 (00.8)  0.2%

According to the SoundFAQ (https://wiki.debian.org/SoundFAQ) /dev/dsp
errors can be fixed by running either:

$ apt-get install oss-compat


$ modprobe snd-pcm-oss

I've done both, but /dev/dsp still does not exist on my system.

The output of lspci -v is:
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset
High Definition Audio (rev 06)
        Subsystem: Toshiba America Info Systems Device 0001
        Flags: bus master, fast devsel, latency 0, IRQ 5
        Memory at d4620000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Root Complex Link

Running alsamixer shows a master channel and a capture channel, both
of which are set to max volume.

Thanks in advance for the help.

Reply to: