[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: firefox-37, where to put

On Thu, Apr 02, 2015 at 05:16:37AM -0400, Gene Heskett wrote:
> wordwrap off so as not to rip up long lines.
> Fun & games but not S&G. Network-Manager had the last word when I 
> excised that piece of insanity, the SOB zeroed out the eth0 settings 
> in /etc/network/interfaces.  Bad dog, no biscuit from me.
> All discovered and I think fixed as I appear to have restored networking 
> now.
> All triggered by discovering that the reason I was into swap all the 
> time was that for the last 12 days I had been running a 32 bit rtai 
> kernel which is NOT PAE, seems I need to edit the default number in 
> /boot/grub/grub.cnf, it is not pointing at a 64 bit 3.2.0-4amd64 
> vmlinuz.  That discovery in turn triggered by firefox spitting out a 
> tummy ache on start attempts.
> I renamed the firefox script in /usr/bin/ which was actually running 
> iceweasel to /usr/bin/firefux, then made a symlink from 
> /home/gene/bin/firefox-37/firefox/firefox from /usr/bin/firefox.
> So, rebooted to a true 64 bit kernel, but 64 bit firefox refuses to run:
> gene@coyote:~$ ls -l /usr/bin/firefox
> lrwxrwxrwx 1 root root 41 Apr  2 04:03 /usr/bin/firefox -> /home/gene/bin/firefox-37/firefox/firefox
> Which is correct.  But
> First try it like the renamed script does it:
> gene@coyote:~$ firefox "$@"
> bash: /usr/bin/firefox: No such file or directory
> Then try w/o the argument.
> gene@coyote:~$ firefox
> bash: /usr/bin/firefox: No such file or directory
> Its 5am, and I don't seem to have even one eye open simultaineously...
> The firefox binary itself
> gene@coyote:~$ ls -l bin/firefox-37/firefox/firefox
> -rwxr-xr-x 1 gene gene 147776 Mar 26 23:51 bin/firefox-37/firefox/firefox

Often, in this situation, it's not the file you're thinking of which
doesn't exist. When executing a binary file, the kernel will return the
same error (ENOENT) for all files necessary to start the binary. In
other words, you can't immediately tell if it's the binary which doesn't
exist, or the libraries it's linked to.

So, as you know the binary exists, run "ldd /usr/bin/firefox" to see
which libraries it's linked against and see if they all exist.

> Its there and executable.  I can't even run it from there with
> sh ./firefox
> or sh ./firefox-bin either of which gets this error:
> gene@coyote:~/bin/firefox-37/firefox$ sh ./firefox
> ./firefox: 2: ./firefox: Syntax error: Unterminated quoted string

Probably because the binary file isn't shell code. You wouldn't have
tried "perl ./firefox", would you?

> I could use a clue, which will probably make me slap my forhead & yell Duh.
> Cheers, Gene Heskett
> -- 
> "There are four boxes to be used in defense of liberty:
>  soap, ballot, jury, and ammo. Please use in that order."
> -Ed Howdershelt (Author)
> Genes Web page <http://geneslinuxbox.net:6309/gene>
> -- 
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: [🔎] 201504020516.37247.gheskett@wdtv.com">https://lists.debian.org/[🔎] 201504020516.37247.gheskett@wdtv.com

Attachment: signature.asc
Description: Digital signature

Reply to: