[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to override fuse args to ntfs-3g to set permissions?

On 26/11/14 08:24 AM, Rick Macdonald wrote:
On 26/11/14 12:23 AM, Scott Ferguson wrote:
On 26/11/14 16:14, Rick Macdonald wrote:
On 25/11/14 08:46 PM, Scott Ferguson wrote:

Are you using Debian??

Scott, I really appreciate your time in helping me, and I realize it's not easy with my typo and perhaps mis-used terminology. As I hinted at, I've been running pure Debian for some 20 years. I forget how long I've been subscribed to this list, but it could be almost 20 years as well. That doesn't make me smart, just old (and happy with Debian).

I did indeed mistype, and it should have been XFCE not KFCE.

I've been googling and posting with the term "auto-mount", but is this more properly "hotplug"? I'm not trying to get the USB drive to mount at boot; that I can do. It mounts when I plug the drive in to the running system, just not with the permissions that I need. I hope I didn't lead anyone to think I'm asking about a boot-time mount issue.

Over the years the hot-plug system (if that's the name for it) seems to have changed a few times, and I admit I've never understood how hal, udev, etc worked/works. It's always worked to some extent, so I've never had to fuss with it.

ntfs-3g's umask/dmask/fmask options all default to 0, but somebody is calling it with dmask=0077,fmask=0177. I haven't figured out the chain of commands involved.

Sorry for replying to my own post...

I see now that it's the XFCE's volume management that is initiating the (hotplug) mount. Some digging found that "udisks" is involved, so I attached strace to the udisks-daemon and found this:

[pid 29472] 10:58:32 execve("/sbin/mount.ntfs", ["/sbin/mount.ntfs", "/dev/sdg2", "/media/WinBackup_", "-o", "rw,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,dmask=0077,fmask=0177"], [/* 3 vars */]) = 0

So the mode that I'd like to change is coming from the udisks-daemon (or its parent). Strace on udevd shows that it's involved but I don't see any file modes.

That's were I'm at now. I played with udev rules a bit but I've never worked with them before.


Reply to: