[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

GTK crashing X?

I've got a pretty old machine (Celeron 2.8 GHz, ATI rage XL). It's been running Debian fine for years, but I reinstalled recently. Installed stable (chose XFCE as desktop environment), everything worked fine (lightdm worked, xfce worked). Did a dist-upgrade to testing (also tried unstable), and now neither lightdm nor xfce works (lightdm goes into an endless crash loop, xfce sends me back to the login screen). I can manually start an X server, and it can display basic programs like xclock fine. But as soon as I start a GTK application (or at least I think it's GTK causing the problem), X crashes with "Segmentation fault at address 0xc" "Fatal server error: Caught signal 11 (Segmentation fault). Server aborting". There's nothing in the log immediately before the error other than the backtrace.

There doesn't appear to be a problem with any of those components individually, since xfce and individual applications will both run perfectly fine if I display them on another machine's X, so I'm not even sure what to file a bug under.

Reply to: