[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GTK crashing X?

On Sun, Jun 29, 2014 at 11:16:58AM -0700, Matt Ventura wrote:
> I've got a pretty old machine (Celeron 2.8 GHz, ATI rage XL). It's been
> running Debian fine for years, but I reinstalled recently. Installed stable
> (chose XFCE as desktop environment), everything worked fine (lightdm worked,
> xfce worked). Did a dist-upgrade to testing (also tried unstable), and now

Did you downgrade to testing from unstable?

> neither lightdm nor xfce works (lightdm goes into an endless crash loop,
> xfce sends me back to the login screen). I can manually start an X server,
> and it can display basic programs like xclock fine. But as soon as I start a
> GTK application (or at least I think it's GTK causing the problem), X
> crashes with "Segmentation fault at address 0xc" "Fatal server error: Caught
> signal 11 (Segmentation fault). Server aborting". There's nothing in the log
> immediately before the error other than the backtrace.
> There doesn't appear to be a problem with any of those components
> individually, since xfce and individual applications will both run perfectly
> fine if I display them on another machine's X, so I'm not even sure what to
> file a bug under.

I'd check the package versions from what you say above about trying stable
unstable and testing. Is the system in a sane state? i.e. does an
apt-get update/upgrade occur without issue?

Just as an aside, if stable was working fine why did you upgrade? 

"If you're not careful, the newspapers will have you hating the people
who are being oppressed, and loving the people who are doing the 
oppressing." --- Malcolm X

Reply to: