[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cryptsetup problem

On 5/06/2014 11:06 AM, Andrew McGlashan wrote:
> I'm not sure that pv isn't part of the problem, so I've adjusted to stop
> using it.

Another failure, this time in /normal/ run, not dropbear environment.

It's not pv.

> Here's a simple bash script that will do the job for me, just started it
> again -- been too busy to follow up before now.
> #!/bin/bash
> function dd_progress()
> {
> 	DD_PID=$(pidof dd)
> 	while [ ! -z "$DD_PID" ]
> 	do
> 		echo "DD_PID: $DD_PID"
> 		pstree -alphG $DD_PID
> 		date
> 		kill -USR1 $DD_PID
> 		if [ ! -z "$(pidof dd)" ];then sleep 300;fi
> 		DD_PID=$(pidof dd)
> 	done
> }
> for crypt_vol in md1_crypt md2_crypt
> do
> 	echo "zero.... $crypt_vol"
> 	dd if=/dev/zero of=/dev/mapper/$crypt_vol bs=128M &
> 	dd_progress
> 	echo -e " .... end $crypt_vol\n\n"
> done

The above script worked fine .... for around 45 minutes.

Oddly I could use a keyboard and screen to enter a username, but never
got a password prompt for hours.  The keyboard was still able to cycle
through ttys though.  No network connectivity either.  So, another reboot.

This seems like a lost cause right now :(

> I am hoping that I won't be needing any special or different kernels for
> this box -- it is a brand new N4800Eco unit (Thecus).  I have two in
> fact, both are behaving the same way.  Hopefully I get one sorted then
> use that knowledge for the other box.

Haven't tried other kernels, don't have time for that now.  Not sure
when I'll be able to revisit this.


Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: