[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade? broke exim4

On 2014-06-03, Mike McClain <mike.junk@nethere.com> wrote:
> Howdy,
>     I hadn't rebooted since dist-upgrade last January then something
> caused a lockup, no video, no keyboard such that I did a hard power off.
>     That was 2 days ago and since I've rebooted exim4 can't connect to
> hence fetchmail can't transfer inbound mail.
>     I've not found any solution on Google that works for me. Exim and
> fetchmail has worked for me for years, since Potato I believe, Debian 2
> something.
>     When I run '/etc/init.d/exim4 restart' exim4 writes to
> /var/log/exim4/paniclog,
>     socket bind() to port 25 for address ::1 failed: Cannot assign
>         requested address: waiting 30s before trying again (9 more tries)
>         and finally: daemon abandoned

You do have a loopback interface in /etc/network/interfaces?

 # The loopback network interface
 auto lo
 iface lo inet loopback

One time, I don't remember how or why it happened, I lost mine somehow
(the loopback interface) and it caused all sorts of delays and problems.

I see you "restarted" exim4.  I think I read somewhere restarting was
frowned upon (I'm not sure where I read that).

I think you're supposed to stop it (service exim4 stop), then start it again
(service exim4 start). Maybe between stop and start check to make sure
it really died a thorough death (no stale zombies, or whatever they're

Reply to: