[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

upgrade? broke exim4

    I hadn't rebooted since dist-upgrade last January then something
caused a lockup, no video, no keyboard such that I did a hard power off.
    That was 2 days ago and since I've rebooted exim4 can't connect to hence fetchmail can't transfer inbound mail.
    I've not found any solution on Google that works for me. Exim and
fetchmail has worked for me for years, since Potato I believe, Debian 2
    When I run '/etc/init.d/exim4 restart' exim4 writes to
    socket bind() to port 25 for address ::1 failed: Cannot assign
        requested address: waiting 30s before trying again (9 more tries)
        and finally: daemon abandoned
    When I try to fetch mail
    mike@/deb73:~> /usr/bin/fetchmail -v -i '';
        1 message for mdmcclain at pop3.nethere.net (4211 octets).
        fetchmail: POP3> LIST 1
        fetchmail: POP3< +OK 1 4211
        fetchmail: POP3> TOP 1 99999999
        fetchmail: POP3< +OK headers follow.
        reading message mdmcclain@mail.nethere.net:1 of 1 (4211 octets)
        Trying to connect to
        fetchmail: smtp listener protocol error
        Trying to connect to failed.
        fetchmail: connection to localhost:smtp [] failed:
            Connection refused.
        fetchmail: Connection errors for this poll:
        name 0: connection to localhost:smtp [] failed:
            Connection refused.
        fetchmail: SMTP connect to localhost failed
        fetchmail: POP3> QUIT
        fetchmail: POP3< This is a multi-part message in MIME format.
        fetchmail: SMTP transaction error while fetching from
            and delivering to SMTP host localhost
        fetchmail: 6.3.21 querying pop3.nethere.net (protocol POP3) at
            Mon Jun  2 12:39:46 2014:
        poll completed
        fetchmail: Query status=10 (SMTP)
    this stopped exim4 again

    I don't see anything suspicious in /etc/ exim4 or fetchmail configs
so rebooted into older kernel and to see if problems went away, no joy.
    In one of the messages I read online someone's problems went away with an
upgrade, so I did an update, upgrade, still no joy.

    I'll readily admit most of what I've tried is flailing. I don't even know
what a port is that exim4 can't connect to, though I suspect it's software since
the hardware allows me to connect to the internet.
    I'm on dialup if that matters.

    One of the messages online suggested running,
'while true; do netstat -tlpn | grep :25 ; sleep 10 ; done'.
This shows nothing unless done right after restarting exim4 which dies after about
2.5 minutes.

    I'm open to suggestions as I don't know where to go from here, but please keep
the suggestions focused on what the problem with exim4 is. It's way too early to
change MTAs which will have a whole other batch of problems.

"So the universe is not quite as you thought it was.
 You'd better rearrange your beliefs, then.
 Because you certainly can't rearrange the universe."
    - Nightfall by Asimov/Silverberg

Reply to: