[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: In Squeeze replacing python version 2.6.6-13~bpo60+1 with version 2.6.6-3+squeeze7

Hash: SHA1

On 2014-04-25 18:07, Ken Heard wrote:
> On 2014-04-25 10:03, Brian wrote:
>> On Thu 24 Apr 2014 at 12:55:26 -0400, Ken Heard wrote:
>>> I am consequently stuck with python 2.6.6-13~bpo60+1 which
>>> seems to work with everything using python, but hplip wants the
>>> "pure" version of python rather than the "unofficial" version
>>> provided by deb.mozilla.net.  So I am back to Andrei's proposed
>>> solution, which I will not be able to try until next month.
>> As you said
>> Apt-get will not however install package python-dev 
>> 2.6.6-3+squeeze7
>> So instead of working against 2.6.6-13~bpo60+1 why not
>> co-operate with it and install python-dev_2.6.6-13~bpo60+1? It is
>> obtainable from
>> http://mozilla.debian.net/pool/iceweasel-esr/p/python-defaults/
>> 'dpkg -i' should get it put on the system. It works for me but 
>> YMMV.
> I tried what you suggested.  The response I received when I ran
> that command follows. ----------------------------------------- 
> BDS:~# dpkg -i 
> /usr/local/share/hplip-3.14.4/python-dev_2.6.6-13~bpo60+1_all.deb 
> Selecting previously deselected package python-dev. (Reading
> database ... 141562 files and directories currently installed.) 
> Unpacking python-dev (from .../python-dev_2.6.6-13~bpo60+1_all.deb)
> ... dpkg: dependency problems prevent configuration of python-dev: 
> python-dev depends on python2.6-dev (>= 2.6.6-1~); however: Package
> python2.6-dev is not installed. dpkg: error processing python-dev
> (--install): dependency problems - leaving unconfigured Errors were
> encountered while processing: python-dev 
> ------------------------------------------

After receiving the previous message it occurred to me to try to
install python2.6-dev. I did so successfully.  I then ran your command
once again; python-dev_2.6.6-13~bpo60+1 was this time successfully

Next was the smoke test; I ran command "sh hplip-3.14.4.run".  It ran
through successfully all the steps except one; it could not install
package cupsys-bsd because that package does not exist in Squeeze --
it is succeeded by cups-bsd.  When hplip-3.14.4.run got to the
"Printer setup" section it returned the message "error: hp-setup
failed. Please run hp-setup manually" and closed down.

So I dutifully ran hp-setup. It produced a window entitled "Smart
Install Device(s) detected".  The text in the window read as follows.

> Smart install is enabled in "HP LaserJet 400 colorMFP M475dw"
> devices. Do you want to download and disable smart install to
> perform device functionalities?

I was given two options "Download and disable" and "Cancel".  The
former was enclosed in a double box, presumably to indicate that that
option is the preferred one.

Not knowing what anything about "smart install" I first selected
"cancel".  I then got another error message: "error: Failed to disable
smart install.  Please refer link
'http://hplipopensource.com/node/367' for more information."

At this point I went back to the previous window and chose the other
option -- to disable smart install.  As soon as I had done so another
message appeared: 'Searching... (bus=usb, search=(None), desc=0)
Receiving digital keys: su - -c "/usr/bin/gpg --no-permission-warning
- --keyserver pgp.mit.edu --recv-keys 0xA59047B9"'

Then the counter -- a succession of -\/|\/- symbols churning around in
the same place -- started.  After 1.5 hours of such churning I thought
it was high time to exit from "hp-setup" and did so.

Any further suggestions, anyone, on how to activate this
printer/scanner/fax machine, etc.?

Regards, Ken
Version: GnuPG v1.4.10 (GNU/Linux)


Reply to: