[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ssh login problem from one particular client

On Thu, Jan 23, 2014 at 09:20:09PM -0200, André Nunes Batista wrote:
> On Thu, 2014-01-23 at 14:07 -0600, Craig L. wrote:
> > 
> > When I tried to reconnect, it took almost 60 seconds for the password prompt to
> > show up. Ever since then this problem occurs from my machine to either of the
> > VMs. I can ssh into the host server and from there ssh into either VM, and I get
> > a password prompt immediately. Today I fired up a VM on my local machine,
> > created the tunnel through the server to one of the remote VMs, and tried to
> > ssh in. The password prompt appeared immediately.
> > 
> > In all cases, once I log in everything responds immediately as expected. It is
> > just the login prompt that is a problem. The remote machines all have
> > UseDNS = no set, and everything has worked fine for several months until this
> > problem yesterday.
> > 
> nmap -sS -P0 -v --traceroute -sV -R -p$PORTNUM $server_ip
> is what I'd do first. Try this same command from a couple of different
> networks and see if there is some kind of unusual machine in your way.
> Maybe change the key + machine used in the reverse connection and test
> to see if problem persists?

Hi Andre, and thanks for the suggestion. As far as I can tell, there
is nothing abnormal and this[1] shows a single device between me and the
server, possibly the switch in the closet down the hall? I know there is a
switch in the server room as well so there should be at least two devices
showing up between here and there, unless one has been removed (highly
unlikely). I can get that information if need be. I haven't engaged our
network team since this is a particular problem involving a single protocol on
a single box).

I also wouldn't suspect something unusual in the network since the VM on my
desktop has no problems, just the desktop itself. FWIW, the network traffic
to and from my desktop has been dropping out like crazy today, but my local
VM doesn't seem to be experiencing any issues. I am composing this on the
remote VM through a connection from the local VM with no problems. This is
really strange because any physical problems would obviously affect the
local VM just as much as the machine it is running on.

> -- 
> André N. Batista

[1] (names changed to protect privacy)
sudo nmap -sS -P0 -v --traceroute -sV -R -p22 server.example.com

Starting Nmap 6.00 ( http://nmap.org ) at 2014-01-24 07:55 CST
NSE: Loaded 17 scripts for scanning.
Initiating SYN Stealth Scan at 07:55
Scanning server.example.com ( [1 port]
Discovered open port 22/tcp on
Completed SYN Stealth Scan at 07:55, 0.10s elapsed (1 total ports)
Initiating Service scan at 07:55
Scanning 1 service on server.example.com (
Completed Service scan at 07:55, 0.01s elapsed (1 service on 1 host)
Initiating Traceroute at 07:55
Completed Traceroute at 07:55, 0.02s elapsed
Initiating Parallel DNS resolution of 2 hosts. at 07:55
Completed Parallel DNS resolution of 2 hosts. at 07:55, 0.00s elapsed
NSE: Script scanning
Nmap scan report for server.example.com (
Host is up (0.00045s latency).
22/tcp open  ssh     OpenSSH 5.3 (protocol 2.0)

TRACEROUTE (using port 22/tcp)
1   0.36 ms tez-r-gw.fw.example.com (
2   0.49 ms server.example.com (

Read data files from: /usr/bin/../share/nmap
Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 0.40 seconds
           Raw packets sent: 11 (484B) | Rcvd: 11 (496B)

Reply to: