[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ssh login problem from one particular client

I have a couple of VMs running on a remote server: one with an older version of
Ubuntu, and one running wheezy. I have an ssh tunnel with X forwarding set up
so that I can access the machines from my system as localhost
(ssh -p 48828 user@localhost and ssh -p 48829 user@localhost).
Yesterday I opened Firefox on the Ubuntu box and was dragging the window to
move it, when it suddenly disappeared. In my connection terminal the message
"write failed, broken pipe" appeared, and the connection to the remote server
was gone.

When I tried to reconnect, it took almost 60 seconds for the password prompt to
show up. Ever since then this problem occurs from my machine to either of the
VMs. I can ssh into the host server and from there ssh into either VM, and I get
a password prompt immediately. Today I fired up a VM on my local machine,
created the tunnel through the server to one of the remote VMs, and tried to
ssh in. The password prompt appeared immediately.

In all cases, once I log in everything responds immediately as expected. It is
just the login prompt that is a problem. The remote machines all have
UseDNS = no set, and everything has worked fine for several months until this
problem yesterday.

So it looks like the problem is something that has changed on my local machine,
but I have no idea what, or where to begin. We have been having intermittent
network issues between here and the building that houses the remote server, and
that is probably what caused the initial connection loss. But I wouldn't think
severing a connection would cause this subsequent problem. Since the server is
on a remote VM I don't think I can ssh in and then run the server in the
foreground to watch it run, can I? I have checked the logs on both ends, but
nothing looks abnormal to me. The only thing I have not tried is rebooting my
machine, but that's so windows and probably not necessary. So I've turned to
y'all for a clue as to how to troubleshoot this issue.


Reply to: