[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Finding a working udev rule for a device



Franz Zinn wrote:
> Hi,
> 
> I have tried making a udev rule for the device
> http://www.syscompdesign.com/WGM201.html, such that it is group owner
> is "plugdev" and has group read/write permissions. However every thing
> I tried does not seem to work. The device nodes (/dev/ttyUSB0) group
> always stays as "dialout". I would be grateful for some insight into
> what is going  wrong. I am using Debian/Squeeze with udev version 164.
> 
> I have tried various choices for SUBSYSTEM(S) include usb, usb-serial,
> and ATTRS including,
> manufacturer, serial etc. I have also tried using a lower number
> (10-wgm.rule) for my custom rule.
> 
(clipped)
>   looking at parent device '/devices/pci0000:00/0000:00:1a.0/usb3/3-2':
>     KERNELS=="3-2"
>     SUBSYSTEMS=="usb"
>     DRIVERS=="usb"
>     ATTRS{configuration}==""
>     ATTRS{bNumInterfaces}==" 1"
>     ATTRS{bConfigurationValue}=="1"
>     ATTRS{bmAttributes}=="80"
>     ATTRS{bMaxPower}=="450mA"
>     ATTRS{urbnum}=="16"
>     ATTRS{idVendor}=="0403"
>     ATTRS{idProduct}=="6001"
>     ATTRS{bcdDevice}=="0600"
>     ATTRS{bDeviceClass}=="00"
>     ATTRS{bDeviceSubClass}=="00"
>     ATTRS{bDeviceProtocol}=="00"
>     ATTRS{bNumConfigurations}=="1"
>     ATTRS{bMaxPacketSize0}=="8"
>     ATTRS{speed}=="12"
>     ATTRS{busnum}=="3"
>     ATTRS{devnum}=="38"
>     ATTRS{devpath}=="2"
>     ATTRS{version}==" 2.00"
>     ATTRS{maxchild}=="0"
>     ATTRS{quirks}=="0x0"
>     ATTRS{avoid_reset_quirk}=="0"
>     ATTRS{authorized}=="1"
>     ATTRS{manufacturer}=="Syscomp"
>     ATTRS{product}=="WGM-201"
>     ATTRS{serial}=="WGVTFKAJ"
>
(clipped)
> parse_file: reading '/etc/udev/rules.d/90-wgm.rules' as rules file
> parse_file: reading '/lib/udev/rules.d/91-permissions.rules' as rules file
(clipped)
> parse_file: reading '/etc/udev/rules.d/z60_usbprog.rules' as rules
(clipped)

It looks like your permissions are being overwritten by the next rule
in line.  Try making the name of your rule begin with z61_ or higher
because the last rule in your directory appears to be
z60_usbprog.rules.  You mentioned trying a name earlier in the order,
but not later.

> 
> -------------------- /etc/udev/rules.d/90-wgm.rules
> -------------------------------------
> 
> SUBSYSTEMS=="tty", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6001",
> ATTR{serial}=="WGVTFKAJ", GROUP="plugdev", MODE="0666"
>
I'd recommend SUBSYSTEMS=="usb" since that is what is in the block of
attributes which include ATTRS{idVendor}.  You should also be using
ATTRS{serial} instead of ATTR{serial}.

Mark Neyhart


Reply to: