[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Scratchy sound with debian wheezy on ASUS A73B series

On 04/01/2013 01:15 AM, Vincent Hobeïka wrote:
Dear debian users,

I have recently set up a debian wheezy on an ASUS A73B series.
Everything went well except that the sound is very scratchy. I can
play sound but there is an additional annoying noise, like a bad
communication on old land lines: scrrrtch scrrrtch. The higher the
volume, the higher the frequency of the scratches (and volume too). It
sounds a bit like a saturated amplifier, but not exactly. It's more
like a bad contact which would always work badly. There is a dual boot
on the computer and the sound is working perfectly well on another non
free operating system. So I suppose that the hardware is ok.

I have checked the volumes and they are not at the max. I have tried
to play with alsa settings without any improvement.
I tried adding a PCM channel in order to reduce this effect (see
.asoundrc below). I can change the volume with three channels: master,
PCM, speaker.
I have tried removing pulseaudio, alsa-base, reinstalling them one by
one... I finally installed paman and pavucontrol and played with them,
but nothing worked.

Any help or hint would be very welcome. Here is my setup:

$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: SB [HDA ATI SB], périphérique 0: ALC269VB Analog [ALC269VB Analog]
   Sous-périphériques: 1/1
   Sous-périphérique #0: subdevice #0
carte 1: Generic [HD-Audio Generic], périphérique 3: HDMI 0 [HDMI 0]
   Sous-périphériques: 1/1
   Sous-périphérique #0: subdevice #0

$ aplay -L

$ cat .asoundrc
pcm.!default front:SB

$ cat /proc/asound/card*/codec#0 | grep -i codec
Codec: Realtek ALC269VB
Codec: ATI R6xx HDMI

$ cat /proc/asound/modules
  0 snd_hda_intel
  1 snd_hda_intel

$ lspci -nn |grep Audio
00:14.2 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI
SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI
Caicos HDMI Audio [Radeon HD 6400 Series] [1002:aa98]

$ lsmod | grep snd

$ cat /etc/modprobe.d/alsa-base.conf

$ aptitude search "~dsound ~i"

$ cat /etc/apt/sources.list
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy main
deb http://security.debian.org/ wheezy/updates main contrib
deb-src http://security.debian.org/ wheezy/updates main contrib

I am completely lost. Can anyone give me some hints regarding this please?

Best regards,


If the BIOS have the parameter "PCI latency timer" try increasing it.

More info <http://www.ibm.com/developerworks/linux/library/l-hw2/index.html>.

Best regards,


Reply to: