[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kobo desktop (native)

On Thu, Nov 29, 2012 at 12:02 PM, Beco <rcb@beco.cc> wrote:
> (1) Native
> ---------------------
> PS. Errors:
> # dpkg -i kobo-desktop.deb
> (Reading database ... 308087 files and directories currently installed.)
> Preparing to replace kobo-desktop 2.1.3-1 (using kobo-desktop.deb) ...
> Unpacking replacement kobo-desktop ...
> dpkg: dependency problems prevent configuration of kobo-desktop:
>  kobo-desktop depends on libusb-0.1-4.
>  kobo-desktop depends on libpng3.
>  kobo-desktop depends on libjpeg62.
>  kobo-desktop depends on libzip1.
>  kobo-desktop depends on libssl0.9.8.
> dpkg: error processing kobo-desktop (--install):
>  dependency problems - leaving unconfigured
> Errors were encountered while processing:
>  kobo-desktop

Hi guys,

Maybe this is the wrong way to do it, but I tried:

I downloaded squeeze packages:

I used :i386 (not sure why, looks like Kobo is i386).

Then finally I got it installed without errors:

# dpkg -i kobo-desktop.deb
Selecting previously unselected package kobo-desktop.
(Reading database ... 308041 files and directories currently installed.)
Unpacking kobo-desktop (from kobo-desktop.deb) ...
Setting up kobo-desktop (2.1.3-1) ...

Now starting the app gave:
$ Kobo
/usr/local/Kobo/Kobo: error while loading shared libraries:
libicuuc.so.44: cannot open shared object file: No such file or

# dpkg --search libicuuc.so.44
dpkg-query: no path found matching pattern *libicuuc.so.44*

# dpkg --search libicuuc.so.48
libicu48:amd64: /usr/lib/x86_64-linux-gnu/libicuuc.so.48
libicu48:i386: /usr/lib/i386-linux-gnu/libicuuc.so.48.1.1
libicu48:amd64: /usr/lib/x86_64-linux-gnu/libicuuc.so.48.1.1
libicu48:i386: /usr/lib/i386-linux-gnu/libicuuc.so.48

So I tried the 48 version. But it still says it needs the 44...

Am I going the correct path?


Dr Beco
A.I. researcher

"My psychiatrist told me I was crazy. I told him I wanted a second
opinion. He told me that I was also ugly."

Reply to: