[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: systemd intermittent startup

On 11/19/12, Tom H <tomh0665@gmail.com> wrote:
> On Sun, Nov 18, 2012 at 11:07 PM, Zenaan Harkness <zen@freedbms.net> wrote:
>> First, systemd worked.
>> Now it hangs on bootup, with the following messages:
>> Nov 19 14:31:12 localhost named[2353]: error (network unreachable)
>> resolving 'B.ROOT-SERVERS.NET/AAAA/IN':

>> Perhaps it's too early for systemd and its bootup time improvements
>> (of course, not booting up takes a lot longer :) ??
> It works fine.
> You might need to fsck your disk but beyond that you're encountering
> delays because your NIC's firmware isn't loading so you network's not
> coming up and named is acting up.

Thank you.

I installed firmware-iwlwifi, now wired _and_ wireless work. Disks are fine.
Wireless I hardware switched-off.
Two wired eth networks, one inbuilt, one usb.
Same hang when I undock (no usb devices, no ethernets, just plain
laptop). Ie same named/avahi/dhclient 'hang' loop.

Default samba4 install on relatively fresh wheezy install.

So (I'm running only successfully on /sbin/init):
apt-get purge samba4
apt-get autoremove
rm /var/log/syslog # let's get really clean output!
# start with systemd
# allow to timeout
# login as root for system maintenance!
#I'm supposed to be happy at this point and say "yay"
vi /var/log/syslog
WFT?!!?! No syslog file.

BIG apologies, I have been deceived by the systemd - I assumed it
would log _something_ to syslog. No. Everything I was seeing (and
reporting on thus far) was init. systemd "hangs" before it logs
anything for me. Then _eventually_ (2 minutes, may be less?) provides
for a root login, which I gratefully accept, but still nothing, no
thing, not a thing (not even an empty syslog file) was logged.
/var/log/syslog.1 (old file) and older exist, but no /var/log/syslog.

Where to?

I'm willing to try to assist a little with shiny syslog on debian, but
this is starting to _not_ look sane, to me.

I believe I ran systemd at least once (suspending and unsuspending
over a day or so), since I tested both systemctl and systemadm
(systemd's gui).

Wish I could be more helpful...


Reply to: