[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Noob Question :-/ ....

On 11/12/12 18:24, David Guntner wrote:
William A. Mahaffey III grabbed a keyboard and wrote:
On 11/12/12 16:27, David Guntner wrote:
William A. Mahaffey III grabbed a keyboard and wrote:
ad[0,6]s1 are the 2 offending partitions. Also, in the interlude, I went
ahead&  e2fsck'ed both partitions, both came back w/ '***** FILE SYSTEM
WAS MODIFIED *****', for different reasons, but nothing tragic, 2
lost/dup nodes on 1, none on the other ....
Question:  What does your /etc/mtab file show for the /dev/ad4s3 mount?
[root@opty165a:/etc, Mon Nov 12, 05:22 PM] 824 # cat mtab
/dev/ad4s3 / ufs rw 0 0
devfs /dev devfs rw 0 0
linprocfs /proc linprocfs rw 0 0
/sys /sys sysfs rw 0 0
fdescfs /dev/fd fdescfs rw 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid 0 0
/dev/ad4s1 /boot ext2fs rw 0 0
[root@opty165a:/etc, Mon Nov 12, 05:23 PM] 825 #

The installer made me format the root partition as UFS, I tried ext2/3,
&  it wouldn't let me proceed .... I don't know if that's a clue or not,
who knows .... I know almost for certain that the *BSD's do not support
ext2/3/4 for writing, only for reading, I don't know why (I'm an end
user, not a kernel hacker), so I am uncertain if the kfreeBSD does in
fact fully support ext2/3/4 for full use ....
Ok, try this just for grins.  Edit your /etc/mtab file, and add the
following line:

/dev/ad6s1 /mnt/ad6s1 ext2fs ro 0 0

(I'm following your example from ad4s1; ordinarily with a Linux kernel
that would just be "ext2").  Also, you can try "rw" instead of "ro" if
you want to see if it can write - again, since your (I'm assuming
working) entry for ad4s1 has "rw" on an ext2 file system.  Then as root
do a "mount /mnt/ad6s1" and see if that mounts the partition.  If it
does, then a "ls -la /mnt/ad6s1" should show you the contents.

Nogo, vi griped that the file was read-only when I opened the file (which I thought to start with) .... I tried to save it w/ ':wq!' from vi after the changes & got more croaking (it said the file had been written since I edited it), so I chickened out .... The more I think about, the more I think ext2/3/4 is *not* supported by the kernel .... grub uses the boot partition (ext2fs), then boots the actual kernel, which wants UFS on its root drive, & I am almost certain that the *BSD's don't support ext2/3/4 for writing, only for reading ....

One other question here, and sorry if you've already answered this, but
is there some specific reason why you want to run Debian with a FreeBSD
kernel instead of the standard Linux one?  (Just a point of curiosity.)
I have installed *BSD's at various times in the past,&  I always noticed
the admirably small RAM footprint&  the austere # of system process
running around. The CentOS 5.7 that was powering this system before its
root drive croaked had 250-ish processes running just keeping itself
organized (runlevel 3, X, no desktops, NFS, Samba,&  whatever else it
wanted, I did no customizing of the install), was using 600-700 MB of
RAM (free -m), w/ only 2 GB on the system (older mbd, stuck at 2 GB). I
had OpenBSD on there a couple of years ago, admittedly w/ no NFS, also
no '-rw' support for ext2/3/4, which is why I went to CentOS, but is was
using about 40 MB of RAM,&  about 30 processes total. This install is
similar so far, only about 30 processes total, 125-ish MB of RAM ....
Still no NFS&  Samba, which will no doubt bump up those totals, but
still .... I used to run SGI's, Octanes, IRIX 6.5.30,&  they only had
about 60 processes total for the OS, w/ desktop, NFS, Samba, etc., about
40 MB of RAM used .... I like lean&  light when it should be that way
.... it's a fetish ....
In my currently playing around with Debian 6.0.6, I personally don't
find it to be all that "fat," but I guess that's just me - to each their
own, I guess. :-)  However, your particular fetish in this case may well
keep you from accessing those partitions - at least, for now....  One
thing of note I found at Wikipedia (ya, I know... :-) ) was the following:

"The Debian GNU/kFreeBSD base system is fully functional, but there
still a few major bugs that need to be fixed and packages that need to
be ported to the system. The kfreebsd-* ports of Debian were included
with Debian 6.0 (Squeeze) as a 'technology preview'."

This may be one of the "few major bugs" that they refer to.  And if it
truly *is* in a "technology preview" state, I expect there will still be
things missing - this may well be among those things.  Guess we'll get a
good idea if the mount suggestion I make above doesn't work. :-)



	William A. Mahaffey III


	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                           -- Gen. George S. Patton Jr.

Reply to: