[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Noob Question :-/ ....

On 11/12/12 16:27, David Guntner wrote:

William A. Mahaffey III grabbed a keyboard and wrote:
On 11/12/12 11:10, Tom Furie wrote:
On Sun, Nov 11, 2012 at 11:50:20AM -0600, William A. Mahaffey III wrote:

[root@opty165a:/etc, Sun Nov 11, 11:44 AM] 593 # mount -t ext3
/dev/ad0s1  /mnt
mount: /dev/ad0s1 : No such device
[root@opty165a:/etc, Sun Nov 11, 11:44 AM] 594 # mount -t ext3
/dev/ad6s1  /mnt
mount: /dev/ad6s1 : No such device
[root@opty165a:/etc, Sun Nov 11, 11:44 AM] 595 #

Both drives were AOK as of Friday when I poweroff'ed the CentOS
rescue disk to replace the root drive, so I *think* they are OK.
They were recognized during the install as ext3 drives. The new root
drive is ad4, a 160 GB SATA drive. What's going on here ? Isn't the
ext3 fs supported under Debian-kfreeBSD ? TIA for any clues&   happy
Veteran's Day.
Are you able to mount those filesystems as ext2? Any ext3 filesystem
should be mountable as ext2.
Hmmmmm .... Really ? I've never heard that, what about journalling ? I
would like to non-destructively access them,&  I wasn't aware of that ....
Yup.  Both ext3&  ext4 are built to be backwards compatible.  The only
thing you lose by using ext2 is the journal.  Well, you lose the ability
to handle the larger file sizes that ext3&  ext4 support, but I'm not
sure what form such an incompatibility.

A decent comparison of the formats can be found here, among other places:


Tried it:

[root@opty165a:/etc, Mon Nov 12, 02:12 PM] 802 # mount -t ext3 /dev/ad6s1 /mnt
mount: /dev/ad6s1 : No such device
[root@opty165a:/etc, Mon Nov 12, 02:13 PM] 803 # mount -t ext2 /dev/ad6s1 /mnt
mount: /dev/ad6s1 : No such device
[root@opty165a:/etc, Mon Nov 12, 02:13 PM] 804 # df
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/ad4s3     ufs   146640898    435318 134474310   1% /
devfs        devfs           1         1         0 100% /dev
          linprocfs           4         4         0 100% /proc
/sys         sysfs           4         4         0 100% /sys
fdescfs    fdescfs           1         1         0 100% /dev/fd
tmpfs        tmpfs     5536380         4   5536376   1% /lib/init/rw
/dev/ad4s1  ext2fs      914501      6515    859193   1% /boot
[root@opty165a:/etc, Mon Nov 12, 02:13 PM] 805 #

I go back to my original question: Is ext3fs supported under
debian-kfreeBSD ? Ext3fs is only supported '-ro', i.e. read-only by the
various *BSD's, AFAIK, *not* '-rw', i.e. *not* read-write, not
full-native fs support, does that restriction carry over to
debian-kfreeBSD ?
Don't know what to tell you here.  That error message typically means
that the mount command doesn't see the presence of the device you're
trying to mount (in this case, /dev/ad6s1).  It doesn't look like it's
complaining about a non-supported file system type; it's complaining
that it doesn't see the device.  You may see the device via other
methods that you're using to see the presence of it, but *mount* doesn't
see it for whatever reason.  I'm assuming that when you do a "ls -l" on
/dev, you actually see a device called /dev/ad6s1....


[root@opty165a:/etc, Mon Nov 12, 05:18 PM] 823 # ll /dev/ad*
crw-rw---- 1 root disk 0, 78 Nov 10 08:34 /dev/ad0
crw-rw---- 1 root disk 0, 80 Nov 12 15:47 /dev/ad0s1
crw-rw---- 1 root disk 0, 82 Nov 10 08:34 /dev/ad4
crw-rw---- 1 root disk 0, 83 Nov 10 08:34 /dev/ad4s1
crw-rw---- 1 root disk 0, 85 Nov 10 08:34 /dev/ad4s2
crw-rw---- 1 root disk 0, 86 Nov 10 08:34 /dev/ad4s3
crw-rw---- 1 root disk 0, 88 Nov 10 08:34 /dev/ad6
crw-rw---- 1 root disk 0, 89 Nov 12 14:57 /dev/ad6s1
[root@opty165a:/etc, Mon Nov 12, 05:19 PM] 824 #

ad[0,6]s1 are the 2 offending partitions. Also, in the interlude, I went ahead & e2fsck'ed both partitions, both came back w/ '***** FILE SYSTEM WAS MODIFIED *****', for different reasons, but nothing tragic, 2 lost/dup nodes on 1, none on the other ....

Question:  What does your /etc/mtab file show for the /dev/ad4s3 mount?

[root@opty165a:/etc, Mon Nov 12, 05:22 PM] 824 # cat mtab
/dev/ad4s3 / ufs rw 0 0
devfs /dev devfs rw 0 0
linprocfs /proc linprocfs rw 0 0
/sys /sys sysfs rw 0 0
fdescfs /dev/fd fdescfs rw 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid 0 0
/dev/ad4s1 /boot ext2fs rw 0 0
[root@opty165a:/etc, Mon Nov 12, 05:23 PM] 825 #

The installer made me format the root partition as UFS, I tried ext2/3, & it wouldn't let me proceed .... I don't know if that's a clue or not, who knows .... I know almost for certain that the *BSD's do not support ext2/3/4 for writing, only for reading, I don't know why (I'm an end user, not a kernel hacker), so I am uncertain if the kfreeBSD does in fact fully support ext2/3/4 for full use ....

In a Linux system, typically a IDE drive (PATA) would be referred to by
the system as /dev/hdx and a SATA or SCSI drive would be /dev/sdx.  I
did some searching to find out about /dev/adx, and it's a BSD thing.
While doing that search I found that FreeBSD itself is supposed to have
some support for non-native (ufs, ffs) file systems such as ext; you'd
think that a Debian build would include that....

One other question here, and sorry if you've already answered this, but
is there some specific reason why you want to run Debian with a FreeBSD
kernel instead of the standard Linux one?  (Just a point of curiosity.)


I have installed *BSD's at various times in the past, & I always noticed the admirably small RAM footprint & the austere # of system process running around. The CentOS 5.7 that was powering this system before its root drive croaked had 250-ish processes running just keeping itself organized (runlevel 3, X, no desktops, NFS, Samba, & whatever else it wanted, I did no customizing of the install), was using 600-700 MB of RAM (free -m), w/ only 2 GB on the system (older mbd, stuck at 2 GB). I had OpenBSD on there a couple of years ago, admittedly w/ no NFS, also no '-rw' support for ext2/3/4, which is why I went to CentOS, but is was using about 40 MB of RAM, & about 30 processes total. This install is similar so far, only about 30 processes total, 125-ish MB of RAM .... Still no NFS & Samba, which will no doubt bump up those totals, but still .... I used to run SGI's, Octanes, IRIX 6.5.30, & they only had about 60 processes total for the OS, w/ desktop, NFS, Samba, etc., about 40 MB of RAM used .... I like lean & light when it should be that way .... it's a fetish ....


	William A. Mahaffey III


	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                           -- Gen. George S. Patton Jr.

Reply to: