[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: what did hwinfo do to my machine?

Kent West wrote:
On 06/03/2012 11:05 PM, Dan B. wrote:
After I ran hwinfo (to detect a modem), my machine runs very slowly at
the beginning of booting.

(GRUB takes about 8 seconds between displaying the the "Welcome to GRUB!"
text and the "error: fd0 read error." text, ...)

What the heck did hwinfo do to my machine?

I can't speak about hwinfo. But the problem seems to be in your hardware somehow.

Well, the _current_ problem is in my hardware.  We don't know yet that
hwinfo doesn't have a problem too (of changing persistent hardware
settings in the process of probing).

I know that in the early days of USB support, some computers thought non-booting USB devices (like a printer) was a boot device, and would look for a boot record there and hang for a long time. We got around that by unplugging the printer until after the POST part of booting.

I'm also suspecting a floppy drive issue, that the BIOS is set to boot from it and one doesn't exist, or some such.

Also, back to the USB printer, perhaps you have a memory card inserted into a memory card slot on the printer (having printed some pictures from it a few days ago, maybe), and the computer is seeing that card via the printer connection and trying to boot from it.

I don't see any way that it's something like that.

I've been rebooting multiple times per day (configuring a new system
and rebooting to check setting), so it's not like I attached or detected
some device days ago, forgot about it, and just now rebooted and ran
into symptoms caused by an earlier change.

I had tried configuring PPP.  pppconfig hadn't detected an attached

On some subsequent boot, I installed hwinfo, ran it a couple of times,
and it detected the modem (after not detecting it earlier, presumably
because of an incompletely plugged-in cable).

On a boot very soon after that (probably the next boot, but I can't
say for sure), GRUB began being very slow.

The only changes in device attachments were 1) connecting and
disconnecting the modem from the serial port and 2) the KVM switching
I've been doing for weeks.

There was a USB memory stick that was attached, but that hadn't
changed in weeks.  Also, after the symptoms started, I removed it, but
the problem remains.

As I said, I wonder if some persistent setting in my hard disks
(SATA disks) got changed.

What tools does Linux have for looking at disk settings (Seagate
Barracuda disks)?


Reply to: