[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Random display freezes [was: Less responsive input...blind-typing]

* John Magolske <listmail@b79.net> [120525 17:13]:
> For a while now I've been experiencing a strange behavior where there
> are frequent and regular "freezes" when typing or issuing commands
> in the shell. All of a sudden I'll find myself "blind-typing" for 3
> seconds or so before a backlog of characters burst onto the screen.

Ok, so I opened up htop to look up & kill off non-essential daemons,
adjusted vm.dirty_ratio and vm.dirty_background_ratio [1], tried
changing and tuning the IO scheduler [2] (switched from cfq to
deadline) ... all to no avail, still these infernal 3-second freezes.

Although I mentioned in my last email this behavior showed up while
plugged into AC power, it turns out that was the one rare exception.
By and large, I only see these freezes while running on battery. And
it does seem to correlate with the hard disk spinning up. But why
should, for example, scrolling the selector bar up in Mutt require
the hard disk to spin up first? (eg, hold down up-arrow key, nothing
happens, hard disk spins up, THEN the selector bar jumps up 5 lines or
so after a 3-second pause).

I'm thinking this must have to do with the graphics somehow. I'm often
listening to music during all this and I *never* hear the audio skip.

As per `hwinfo --gfxcard` :

Model: "Intel Mobile 4 Series Chipset Integrated Graphics Controller"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x2a42 "Mobile 4 Series Chipset Integrated Graphics Controller"
Driver: "i915"
Driver Modules: "drm"
Driver Info #0:
  Driver Status: i915 is active
  Driver Activation Cmd: "modprobe i915"

Even in doing something as simple as moving the text cursor around
while holding down an arrow key, there'll be these periodic 3-4
second freezes, after which the cursor will jump ahead the distance
it would've traveled in that time. I'm beginning to wonder if this is
just normal behavior that everyone puts up with, but I find that hard
to believe.

I have laptop-mode enabled...maybe try messing around with the settings
in laptop-mode.conf next?

Any suggestions would be greatly appreciated.

[1] An older message about an older kernel (I'm on 3.2.0-2-686-pae),
    but the description sounds a lot like what I'm seeing:

tried looking at these too:

[2] This is about dealing with the interactive performance when
    booting from a flash drive (I'm running off a spinning disk),
    but has some interesting discussion re tuning the scheduler:



John Magolske

Reply to: