[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Files and directories showing in CLI but not in GUI

On 13/05/12 01:42, Marc Shapiro wrote:
On 5/13/12, Indulekha<indulekha@theunworthy.com>  wrote:
On Sun, May 13, 2012 at 12:22:04AM +0000, Marc Shapiro wrote:
On 5/12/12, Indulekha<indulekha@theunworthy.com>  wrote:
On Sat, May 12, 2012 at 11:43:43PM +0000, Marc Shapiro wrote:
I had some problems with one of my drives last week (see "System no
longer boots" and "How to remove a PV from an LVM VG?"

Now my problem is different, and stranger.


The next day I was unable to boot into the new system without being
dropped into a maintenance shell.  Aaaargh!  So I booted into the live
system, again.  I looked for my missing files and directories again.
Why would I expect to see them?  I don't know.  Desperation, perhaps.
The file browser did not show them.  Then I tried something different.
  I opened a terminal, did a 'cd' to my old home directory which I had
mounted at /mnt and did an 'ls'.  Lo!  And Behold!  The missing
directories were there.  I did a 'cd' into my main documents
directory, followed by 'ls' and my files were all there.  They show up
from the command line, but not from the GUI!

Now I really started to wonder.  I opened OpenOfficeCalc aqnd tried to
browse to the directory and file that I had just seen.  Nothing.  The
directory did not show up.  Then I clicked on the icon to 'Type a File
Name' and entered the name of the missing directory, followed my a
slash.  All the files showed up!  I selected one of the large .ods
files that I use a lot.  A message came up, saying:

Document file 'xxxxx.xxx' is locked for editing by:
xxx ( 06.05.2012 15:49)
Open the document read-only or open a copy of the document for


So my question is: Why do some of my files and directories show in GUI
apps, but not all of them, while all of them seem to show up just fine
from the command line?

Does anyone have any ideas on this?  If all of my files are actually
on the disk, in good order, why can I only see them from the command
line?  Is there something that I can do to make all of the files and
directories visible in GUI apps, as well?  This would make my life a
whole lot easier.

Thanks for any help.


Sorry, default Debian installation, so Gnome and Nautilus.

Also Open Office and Gnome Terminal.

Everything also shows up fine from the command line if I switch to vt
1 cd to the directory and then ls.

Something to do with gnome or nautilus then, I'd think...
Sorry I'm not more helpful, I don't use those.
You could try creating a new user account and see if it happens
there too -- then if it doesn't you know there's probably an error
of some sort in a config file.
If this was caused by an update, apt-get -f install might work...

As I mentioned above and in the listed previous threads, this was a
new install, but the home partition that is acting strangely s from a
previous install.

My first thoughts, before doing *anything* else, would be BACK UP THOSE FILES!

Then start investigating.

I'd next do a fsck -n to see if any file system damage shows, but not trying to repeair it until I see what there is.

It's odd that the files/directories don't show in gnome/nautilus. Perhaps a permissions/attributes thing?

I'm guessing Open Office creates a lock/work file while working on a document and it has found one of those.


Reply to: