[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Files and directories showing in CLI but not in GUI

On 5/12/12, Indulekha <indulekha@theunworthy.com> wrote:
> On Sat, May 12, 2012 at 11:43:43PM +0000, Marc Shapiro wrote:
>> I had some problems with one of my drives last week (see "System no
>> longer boots" and "How to remove a PV from an LVM VG?"
>> Now my problem is different, and stranger.
>> I thought that I was going to need to get filesystem recovery software
>> to retrieve at least some of my data.  Meanwhile, I obtained a spare
>> 80 GB HD and a live DVD ROM which contained Debian Squeeze.  I could
>> boot to the live system and I did an install onto the 80 GB drive.  I
>> rebooted into the new system and it seemed OK.  I installed R-Linux to
>> try and recover my files, but it did not see my old drive (from which
>> I had done the pvmove).  It was getting late and I did not want to
>> leave the system up untill I knew that everything was working
>> reasonably.  So I powered down.
>> The next day I was unable to boot into the new system without being
>> dropped into a maintenance shell.  Aaaargh!  So I booted into the live
>> system, again.  I looked for my missing files and directories again.
>> Why would I expect to see them?  I don't know.  Desperation, perhaps.
>> The file browser did not show them.  Then I tried something different.
>>  I opened a terminal, did a 'cd' to my old home directory which I had
>> mounted at /mnt and did an 'ls'.  Lo!  And Behold!  The missing
>> directories were there.  I did a 'cd' into my main documents
>> directory, followed by 'ls' and my files were all there.  They show up
>> from the command line, but not from the GUI!
>> Now I really started to wonder.  I opened OpenOfficeCalc aqnd tried to
>> browse to the directory and file that I had just seen.  Nothing.  The
>> directory did not show up.  Then I clicked on the icon to 'Type a File
>> Name' and entered the name of the missing directory, followed my a
>> slash.  All the files showed up!  I selected one of the large .ods
>> files that I use a lot.  A message came up, saying:
>> Document file 'xxxxx.xxx' is locked for editing by:
>> xxx ( 06.05.2012 15:49)
>> Open the document read-only or open a copy of the document for editing.
>> The x's above were the file name that I was trying to open and my
>> login on the old system.  If I select Open Read-Only the file opens
>> right up.  Other files open without the warning.  I probably had that
>> particular file open when the system went wonky (it is almost always
>> open) and that is the reason for the warning dialog.
>> So my question is: Why do some of my files and directories show in GUI
>> apps, but not all of them, while all of them seem to show up just fine
>> from the command line?
>> Does anyone have any ideas on this?  If all of my files are actually
>> on the disk, in good order, why can I only see them from the command
>> line?  Is there something that I can do to make all of the files and
>> directories visible in GUI apps, as well?  This would make my life a
>> whole lot easier.
>> Thanks for any help.
> ??
> Gnome/KDE/xfce4/wmii/ratpoison...
> Nautilus/Dolphin/Thunar/pcmanfm...
> ??

Sorry, default Debian installation, so Gnome and Nautilus.

Also Open Office and Gnome Terminal.

Everything also shows up fine from the command line if I switch to vt
1 cd to the directory and then ls.

Marc Shapiro

Reply to: