[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Instalation and kernel headers

On Fri, May 11, 2012 at 09:50:52AM +0200, Pedro Alexi Perez wrote:
> Hello,
> I am trying to install Virtualbox, and after several times with the
> same error, I try to check all the steps of the installation in
> depth, and I see this message
> First Installation: checking all kernels...
> Building only for 2.6.32-5-amd64
> Building initial module for 2.6.32-5-amd64
> Then I check my kernel, and I see that (aparently) my installation
> has the 64 bits architecture
> $ uname -a
> Linux linuxpc 2.6.32-5-amd64 #1 SMP Sat May 5 03:03:41 UTC 2012
> x86_64 GNU/Linux
> But I am pretty sure I installed the 32 bits version. In fact, if I
> revise the /etc/apt/sources.list file, I have this line
> deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official i386 DVD
> Binary-1 20120128-12:53]/ squeeze contrib main
> For sure, I tried to install the 64 bits version of Virtualbox, and
> I got an error because the wrong architecture.
> And, of course, my question is: what's happen? I have a 32 or 64
> bits installation?

You might be running a 64-bit kernel in a 32-bit userspace. I ran such
a system for quite some time until my last HD upgrade. 

Unfortunately, virtualbox is unhappy in such a system, so you have to
set up a 64-bit chroot. There's information on the VB wiki here:
<https://www.virtualbox.org/wiki/Setup_Jail>. It's kind of a PITA, but
it works. 


Dave Thayer           | Whenever you read a good book, it's like the 
Denver, Colorado USA  | author is right there, in the room talking to 
dave@thayer-boyle.com | you, which is why I don't like to read 
                      | good books. - Jack Handey "Deep Thoughts"

Reply to: