[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DHCPOFFER lost in transit :-)

Ok, the last message probably isn't true. But...

Setting up the DHCP server on the AP (with a separate address pool) seems to have solved the problem for now.

As I said I know very little about networking, and I had assumed that when the AP was setup as a repeater, it worked transparently and automagically, as a signal amplifier. It seems this is not the case, at least with this particular AP.

I think that configuring the AP as a DHCP Relay would also have worked except that this model does not support it.

Hope this helps someone, and thanks!

On 09/02/2012 11:02 πμ, Panayiotis Karabassis wrote:
Update: I've narrowed this down. At the times of the problem, the server can connect to the laptop (e.g. ssh or ping) but the laptop has no connectivity to the laptop. I have no idea why this is happening.

On 08/02/2012 09:51 μμ, Panayiotis Karabassis wrote:
On 08/02/2012 06:09 μμ, Camaleón wrote:
On Tue, 07 Feb 2012 21:09:21 +0200, Panayiotis Karabassis wrote:


Well, the laptop hasn't disconnected yet, but my smartphone doesn't
connect at all. It's stuck at the "receiving IP address" stage.

The DHCP server runs on my desktop so I have complete access to it. The
X3000 is configured as a DHCP relay.

Syslog shows the DHCPDISCOVER request received from the desktop, and
answered with a DHCPOFFER (both via the router). But the packet (or
whatever it is, sorry) never arrives, or if it arrives, is ignored by
the smartphone.

I don't know much about Android (which the cellphone is running) and I
would prefer to leave it alone if possible.

Do you have any ideas about the cause of this problem?
Mmm, I would start by discarding something wrong between your device and
DHCP server. The less players in the game, the better to start finding
the culprit :-)

How to do that? By configuring the smartphone with static network data
(manual IP, gateway, netmask, dns...).

If that solves the issue it means your AP is interferring/filtering
between the DHCP server and your device and this will require additional
Thanks. Actually the problem happens on the laptop as well, which is fortunate because it means:
a) The smartphone is good.
b) I have access to a full GNU/Linux system to troubleshoot.

I tried with the access point removed from the way (the signal strength is lower but non-zero) and it doesn't solve the problem.

I tried with static IP and it works.

What does this mean? My guess is that:
a) The AP is not the culprit.
b) This is DHCP specific.

Also around the time of the DHCP "dialogues" I see in the server's logs some "network unreachable" errors from other services (named). I had written a cron script to reconnect the server on the event of connectivity loss, which runs every minute. Perhaps it isn't doing its job.

I know very little about networking, I have been reading on the DHCP protocol, and one point of interest is that DHCPOFFER packets are broadcast. So I tried changing the broadcast address of the DHCP server from to I am waiting to see if the problem will reappear.

Many thanks.

If that still does not solve the issue and you lose connection very
quickly or can't still connect to the AP at all, then the problem is
located elsewhere, either on the smartphone or/and the AP (low signal
strength, filters, an unexpected incompatibility with specific auth


Reply to: