[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Everything seems to cause a reboot

I hope I am sending to the right place.  I really have no idea how to deal
with this.  I'll have to describe the problem in detail, since I cannot
assign it to a package or anything.  I have tried searching for a similar
problem but can't find one.  I am not a complete newcomer, but I am not
much of an expert either.

I have a i7 quad core 2600K, running current squeeze 6.0.3 with default
Gnome installation.

2.6.32-5-amd64 kernel, 8 GB ram.

When I try to shutdown, reboot, logout, switch user or Ctrl-Alt-Fn to
switch tty the machine does a hard reset and reboots.

It does not do this if I use  sysv-rc-conf to turn off gdm, so that it
boots into a CLI instead of GUI.

SO if I boot onto bare CLI, either runlevel 1 or runlevel 2 but with gdm
unchecked in sysv-rc-conf, I can work away, run applications, switch ttys,
use the network, etc, and then

shutdown -h now


shutdown -r now

and the machine shuts down gracefully.

BUT If I type gdm and enter the gui, then I cannot shut the machine off
gracefully, even from an xterm.  And if I try to Ctrl-Alt-F1 to go to a
text tty, it does a hard reset and reboots.

Everything else works fine, but this is crippling.  It seems to be
software because the machine behaves find in CLI mode.  It is not a
problem with keyboard, or not solely, because I have the hard reset
prpblem whether I logout vie menu option in the System Menu or whether I
try to do it from CLI.  The tty switcher could be a keyboard issue, I
support, with the wrong codes being sent, but I have no idea how to fix
that, and I've treid reading around the web but I can't find anything I
can use.  I have an IBM Model M 101 keyboard.  X seems to think I have a
105 key board, but I can't see how that can be the problem.  But it does
seem like it might be something to do with the Xorg config I guess, but I
don't know how to fix that.  Tried a simple-minded Xorg -configure, but it
did not help.




Reply to: