[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: install glitch - re. networking

Walter Hurry wrote:
On Mon, 07 Nov 2011 16:03:14 -0500, Miles Fidelman wrote:

Walter Hurry wrote:
On Mon, 07 Nov 2011 15:43:24 -0500, Miles Fidelman wrote:

I find myself in an odd situation:

- I have a box I use as a sandbox, at home - I've installed all kinds
of different distributions on it over the past couple of years

- I recently installed OpenSuse with no problems, but then I tried to
reinstall Debian (Squeeze) off a CD-Rom, and the installer hangs when
it goes off to detect network hardware -- this is repeatable

- if I just let it boot the OpenSuse distro that's currently on the
hard drive, everything comes up fine - so the NIC, DHCP on our home
LAN, and so forth all are working

- so.... any thoughts on what might be going wrong, or how to track
down what's happening?

note: I'm pretty sure that I installed Squeeze on this box at some
point, but it could be that the last Debian install was Lenny - and
recent discussion suggests that some of the network plumbing has
changed, perhaps in ways that are incompatible with my network card.

Thanks for any suggestions.
Here's a suggestion: Next time you ask a question like this, tell us
what NIC you have.
Easier said than done - the box is an off-brand box assembled by a local
computer store - there's a broadcom chip on the motherboard, and an
Intel card that I installed separately - but I'd have to do some
dissassembly to find specific model numbers (or figure out what commands
work in OpenSuse to grab the information).  [Now if these were the
production servers, in the data center, I'd have no problem providing

Up to now, hardware autodetect has worked just fine - finding both NICs,
identifying them, and giving me a choice.  Now it all just hangs.  I
expect that I could escape out of the installer, and plug in some magic
incantations - but a little guidance is what I'm looking for.  (I have a
vague memory that there's a package of non-free NIC drivers floating
around that might need to be installed for the broadcom chip to work,
but not the Intel one.)
So OpenSuse doesn't have the standard commands to list your PCI and/or USB
hardware? That's difficult to believe.

Well, ok... I had to remind myself about 'lspci' and find Suse's GUI-based configurator (all my other systems have lshw installed, the basic OpenSuse install doesn't).

Looks like:
eth0 is a SiS900 Fast ethernet device - not configured
eth1 is an Intel 82557/8/9/0/1 Ethernet Pro100 (Rev 10) - it seems to be picking up a DHCP address

So the question remains, why doesn't the Squeeze installer see either of them - or more to the point, why does it hang when it goes looking? The installer goes off into the "detecting network hardware" step and never returns - no timeout, no error message, no nothing. That sure seems like a bug, or at least something funny, to me.

Ok... now this is even weirder:
- ^C to get back to the installer menu
- go on to the next step (configure network hardware)
---- gives message: previous step: detect network hardware - select, it hangs ---- instead: tab to "go back," return - now up comes: select primary network interface, and lists both cards
- lets me select one, but then autoconfig fails (for either card)

Aborted, and just for the heck of it stuck a Lenny installer in the CD drive. It gets through network configuration just fine.

Then stuck a copy of SystemRescue CD in the drive, let it start up, typed 'net-setup eth0' and networking was off and running.

- OpenSuse does the right thing
- SystemRescueCD does the right thing
- the Lenny installer does the right thing
- the Squeeze installer has trouble finding and configuring my NICs

Seems pretty weird, and pretty Squeeze-specific. Any thoughts on what might be going on, or how to diagnose further?

(I guess one last thing to try would be to burn a newer version of the Squeeze installer, but the one I tried was just fine for building a couple of servers not too long ago.)

Miles Fidelman

In theory, there is no difference between theory and practice.
In<fnord>  practice, there is.   .... Yogi Berra

Reply to: