[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Install kde-desktop on existing debian install

Camaleón <noelamac@gmail.com> writes:

> On Sun, 09 Oct 2011 09:51:13 -0500, Harry Putnam wrote:
>>> I suppose you installed the right pattern for you current running
>>> Debian system, right? That is, kde-full for "squeeze" if you are
>>> running squeeze, kde-full for wheezy, if you are running wheezy, etc...
>> I see only 1 pkg when I run `aptitude search kde-full' p   kde-full     
>> - complete KDE Software Compilation [...]
>> And that is what I installed
> Sadly, that tells no much.
> How does your "/etc/apt/sources.list" file look like?

  deb http://ftp.us.debian.org/debian/ wheezy main
  deb-src http://ftp.us.debian.org/debian/ wheezy main

  deb http://security.debian.org/ wheezy/updates main
  deb-src http://security.debian.org/ wheezy/updates main

>>> You mean you were not able to login with your user account (no desktop
>>> at all, just the command line)?
>> Sorry, no there was a kdm login then a black screen with only a terminal
>> emulator running.  (Not a console screen but a black colored screen in
>> X)
> Have you restared the computer?

Yes, and reinstalled kde-full

>>> It is still unclear to me at what stage you find right now, so:
>>> 1/ If you are left into a tty and no GUI login is possible, try to
>>> launch "startx" and see what happens.
>> I am able to login to an X session.  

> Good.

I should have explained further that the X session I am able to log
into is by startx with .xinitrc aimed at fluxbox.

>>> 2/ If you can login with your usual account but things are completely
>>> messed up, try to create a fresh new user and login with it.

Not into kde... only into console now.

On reboot I find I am not presented with a gui login.  Only the

I find some very oddness in install of kdm.  After install of kdm I

dpkg -L kdm|grep bin

There is now executable being installed.  And yet

  apt-file search  /usr/bin/kdm (reports:)
  kdm: /usr/bin/kdmctl
  kdm:  /usr/bin/kdm 

And further the script in /etc/init.d/kdm looks for that executable.

So at this point
  service kdm start

reports back nothing but:

   service kdm status says:

  kdm is not running ... failed!

Little wonder since there is no executable.

I tried `aptitude reinstall kdm'
Only to find it is not installed.  This is very confusing.  It would
seem that installing kdm-full would at least install the display

Further it would seem the dpkg -L kdm would not list files if kdm were
not installed.

So I am now installing kdm 

I'm sure things will change with an actual display manager in tow.
I'm rebooting now and see what happens.

Reply to: