[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Rsync fails on copying large file

On 30/08/11 11:43, Johann Spies wrote:
Hallo Alan,

On Tue, Aug 30, 2011 at 10:56:02AM +0200, Alan Chandler wrote:
I use Rsync between two of my machines to facilitate regular backups.
In the case I have a problem with I am attempting to copy a file using
the double colon (::) method to talk to the rsync daemon on the
receiving end.

I have been having regular failures of this backup and have traced it
down to copying a 60Gb .vdi (Virtual Box virtual disk image).  The
manual command, and error I received when I just tried it was...

Did you specify a folder/directory for rsync to use as temporary space
and did that folder have enough space for a 60Gb file?  If you do not
specify it, it will use /tmp and I have in the past sometimes
experienced problems because /tmp did not have enough space for a very
large file.

I didn't specify it, and according to the man page it will use the same directory as the receiving file. This is in a partition with 151GB free.

I tried to check it, even with the --partial flag, I can't find any evidence of any new section of file reaching the destination

Alan Chandler

Reply to: