[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Pixel garbage when opening context menus

On Tue, 30 Aug 2011 18:48:26 +0200, Steve B wrote:

> On Tuesday 30 August 2011 12:49:49 Camaleón wrote:
>> On Tue, 23 Aug 2011 13:02:57 +0200, Ralf Jung wrote:
>> (...)
>> > Now I wonder, which package do I have to report the bug against? It
>> > can hardly be the driver, but it could be everything else in the
>> > graphics stack, as far as I can tell. I also wonder whether anyone
>> > else is having the same problem.
>> I would run some tests, for instance, run a Debian LiveCD with GNOME
>> +radeon driver (to discard the DE) or even try with another VGA card
>> (to discard a hardware issue) and see how it goes.
>> If GNOME does not expose the same behaviour, I would open a bug against
>> KDE base libs. If GNOME does show the same thing, open the bug against
>> radeon drivers (the bug needs to be open against open source drivers).
> Same problem here on a desktop with IGP (Radeon HD 4200). I don't
> remember when it appears but it's recent.
> I just noticed that it only occurs on QT based applications, i.e. the
> "pixel garbage" appears on right-click with KDE apps and VLC but not
> with Iceweasel.

I'd say that's a very good catch :-), if it's limited to the Qt stack 
then you've done half of the debugging work.

> System: Debian wheezy 32bits, KDE, no compositing, all effects disabled,
> only xserver-xorg-video-radeon installed.
> I ran a LiveCD recently (for other purposes) without noticing any bug
> wathever the DE was (Gnome, KDE, LXDE, XFCE) but the LiveCD is not
> Debian based (Hybryde NirvanOS).

Have you both considered in opening a bug report at Debian BTS for 
this? :-?



Reply to: