[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wheezy won't boot any more -- SOLVED

On Thu, 11 Aug 2011 01:36:37 +0000, Hendrik Boom wrote:

> Just upgraded a squeeze system to wheezy.  It rebooted and ran just fine
> (except that my scanner still doesn't work, but that's another issue.)
> Then I did dpkg-reconfigure sysv-rc.  It checked it was safe to adopt
> the new parallel boot, and subsequently the machine booted faster.
> But today it won't boot.  It seems to start up fine, but then it gets
> suck after the message "Starting NFS common utilitues: statd"
> Any ideas?

Taking a clue from but report 612002, I booted squeeze (s copy that was 
still lurking on another partition) and chrooted into wheezy's root 
partition.  I fired out aptitude, and found that was blocked from 
upgrading from a previous version.  aptitude was suggesting removing nfs-
common altogether, which i refused to do.  But looking at the 
altermatives, one of them was to remove portmap, which conflicted with 
rpcbind.  The descriptions of these two packages seemed at least somewhat 
similar, so I decided to try letting it remove portmap.  It upgraded nfs-
common to 1:1.2.4-1, and noew it boots.

By the way, when I chrooted to the wheezy system, aptitude complained 
that it couldn't find the lock /var/lock/aptitude, but it ran anyway.  
It's not clear to me why it would work without being able to access the 
lock, though I'm glad it did.

-- hendrik

Reply to: