[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

lenny->squeeze upgrade - failed with grub-pc upgrade

In the process of upgrading from debian lenny amd64 to debian squeezy
amd64 I was able to successfully upgrade to kernel 32 and new udev.
Then after reboot I followed with apt-get dist-upgrade.

Everything went fine, but towards the end I was asked to upgrade to
grub-pc. During this choice I was asked to specify mbr to install new
boot loader. I've selected my "flash" drive that I have used before to
hold my "boot" partition I believe.

After restart I can only see "GRUB>".

While Recovering from grub-pc install failure. I've started from cd
(rescue) mode. I then assembled my raid partition (sdb1,sdc1,sdd1) and
executed into shell of my lvm root group mapper_xyz_root. From there I
run "upgrade-from-grub-legecy" and this time I've selected my usb and
sda to install grub.

Still no lock.

Then I tried "update-grub"

Now I get "grub loading...
no module name found"

What should I do now? I've logged in with rescue cd again and now my
/boot partition no longer holds other files except for "/boot/grub/.."
What happened to my kernel files 26 and 32 that were on the /boot?

What are my choices on installing grub-pc? Do I need "boot" partition?
What should be on it? Why did files got removed? Should I be
installing grub on my lvm root group? or sda? or /boot flashdrive?

I would appreciate some guidance on this.

Thank you,

Reply to: