[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

(almost solved) Re: [Feedback needed] "brcmsmac" wifi driver in testing

On Sun, 31 Jul 2011 15:07:28 +0100, Brian wrote:

> On Sun 31 Jul 2011 at 13:22:45 +0000, Camaleón wrote:
>> On Sun, 31 Jul 2011 15:24:11 +0300, Volkan YAZICI wrote:
>> > Oh, and I forgot to say in the previous mail: Turn everything
>> > fiddling with the wifi interfaces off, that is, nm, hostapd, etc.,
>> > before trying any manual method.
>> Hey, that did it! At least for wlan2 card :-)
>> By stopping NM now wpa_assintant runs fine for wlan2 while wlan0 (the
>> one with broadcom chipset) fails in the same way it did.
> By default wpa_supplicant will use the wext driver. Try nl80211.
>   wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -D nl80211
>   -i wlan2
> Also you could reduce the wpa_supplicant.conf file down to
>   ctrl_interface=/var/run/wpa_supplicant
>   network={
>       ssid="WLAN_6D"
>       psk="my_pass"
> }
> and let the supplicant take care of negotiating encryption.

Tried with both ("-D nl80211" and reduced conf file) but I get the same ;-

Trying to associate with 00:26:44:df:60:91 (SSID='WLAN_6D' freq=2452 MHz)
Authentication with 00:26:44:df:60:91 timed out.

It cannot even associate with the AP, this cannot be normal. 

Okay, let's make a brute-force test. I've removed the power cord of the 
netbook and walked next to the AP, et voilà, now it associates fine...  
go figure :-o

Now at least I know all of the settings are fine and driver works, just 
will have to dig a bit why on the earth it cannot associate with the AP 
that on the next room...

(5 minutes later...)

Grrr! If I unplug the power cord it also connects fine from the original 
place! WTF!! I'm afraid I have another thing that requires investigation.

Well, thanks you both, Volkan and Brian, for hanging there. I will post 
further findings I'll discover to make the connection stable but at least 
now I have a place to start :-)



Reply to: