[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with PAE kernel sort of solved.

On Fri, 29 Jul 2011 11:02:52 -0400, Frank McCormick wrote:

> On 29/07/11 10:14 AM, Camaleón wrote:
>>>     Yes, that I guess is why the system now "sees" only one CPU when I
>>> have a dual core. But I still fail to understand why turning off
>>> hyper-threading allows the kernel (supposedly who only major change is
>>> use of the PAE extension) to boot when it wouldn't before.
>> Because PAE is disabled?
>    cat /proc/cpuinfo show PAE is not disabled in this machine. For some
> weird reason the PAE kernel can't boot with hyper-threading enabled. BTW
> I don't have a dual-core cpu as I once thought.

That can be indeed a bug in the BIOS. Disabling HT capabilities should 
not make the "pae" flag to be exposed in the OS :-?

>> Something seems seriously broken with your machine and PAE (HT/PAE
>> combo), dunno what nor why because your system looks PAE-aware and
>> capable :-?
>    I have since discovered a couple of other people who have the same
> problem...all on machines using older (circa 2002) Intel boards and
> cpu's.


Then you better disable HT and use a "non-pae" kernel until someone can 
provide more data on why/how the error is triggered. What happens with a 
pae kernel of another distribution? Or with an own-complied kernel? Are 
you experiencing the same? If "no", this can be a start point to further 
debug the problem. If "yes"... well, time to upgrade that motherboard or 
live with a 486 kernel O:-)



Reply to: