[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Adventures multi-booting late 2003 iBook G3 (was: What is this Apple Bootstrap thing of which the installer speaks?)

Hash: SHA1

I actually found a horribly convoluted way of installing Debian
without breaking Mac OS 9.2.2. However, my G3 does apparently have
hardware support for large disks. I can partition the whole disk
from Tiger and Mac OS 9.2.2 can still be installed and booted. I
haven't tried asking Mac OS 9.2.2 to actually boot from or mount
any partitions over the 128GB limit, but it doesn't appear to be
bothered by it. I'm not sure what is happening differently on your
computer. According to Speedtools, it ought not be a problem for
Mac OS Classic so long as Classic doesn't actually need any
partition above the 128GB limit. I don't use Speedtools, but that's
what they say ought to happen if you boot without it.

I do remember on one occasion, I partitioned Debian with partman
but did not install yaboot, and Mac OS 9.2.2 still booted, until I
installed yaboot. On another occasion that I installed Debian w/out
yaboot, having partitioned with partman, Mac OS 9.2.2 did become
broken. The first time, the disk was initially partition with OS X -
- - the second time, with Classic. Perhaps when partman saw the
Classic parition table was smaller than the actual disk, it felt an
obsessive compulsive need to fix it by re-initializing, and in
doing so, broke the partition map. I'm really not sure.

In any case, for me at least, bypassing both partman and automatic
yaboot installation fixed the problem, although it did involve
wiping the disk and starting from scratch. It sound like maybe you
were having a slightly different problem. I think perhaps there are
multiple bugs here.

On 20/05/2011, Joel Rees <joel.rees@gmail.com> wrote:
> I blogged about this a couple of years back. (Fedora, rather than
> Debian.) You may have discovered this all the hard way by now, but
> I'll post the link anyway:
> http://reiisi.blogspot.com/2009/05/fedora-on-old-clamshell-
> I think the only thing the blog really adds is that you can
> get around the Mac OS 9 partition being walked on by something
> the following:
> After your fresh install of Mac OS 9, make sure it's updated as
far as
> you want the Mac OS 9 system updated, and make sure there's a
copy of
> the Apple Hard Disk utility on the Mac OS 9 partition.
> iBooks with Firewire can boot from an external drive. After a
> model number (check Apple's hardware pages) hey can boot from USB
> well as Firewire. So you can make a copy of your booting Mac OS 9
> partition (with Apple's disk imaging utility, or, even by
> drag-and-drop copying, usually) and boot from an external drive in
> some cases.
> If that doesn't work for you, you should still be able to copy the
> partition and burn a CD-R (but not CD-RW) from the copy, and end
> with a bootable CD from which to run Apple's HD Utilitiy.
> (Ergo, to get you out of the bind when Debian's installer walks
on the
> Mac OS 9 partiions.)
> (I did file a bug on this in Fedora's Bugzilla, but they couldn't
> the hardware and the spare personnel with the technical expertise
> together long enough to fix it, I think. Wish I had the time to
> at it myself.)
> On Fri, May 20, 2011 at 4:10 AM,  <annathemermaid@hush.com> wrote:
>> Hash: SHA1
>> On Wed, 18 May 2011 17:23:26 +0000 annathemermaid@hush.com wrote:
>>>On Thu, 05 May 2011 18:14:43 +0000 Roger Leigh
>>><rleigh@codelibre.net> wrote:
>>>>> Now that Debian is up and running, is there documentation
>>>>> explaining how to make yaboot offer options to boot OpenBSD
>>>>> NetBSD?
>>>>It should be possible, but AFAIK it's currently broken:
>>>>Looks like it's simple to fix, but there wasn't anyone who could
>>>>test it properly.
>>>I've been having a more serious issue with yaboot: it seems to
>>>wreck the Mac Os Classic disk drivers so Mac OS 9.2.2 can't boot
>>>anymore. Instead, it just shows this sort of flashing flopping
>>>image. Apparently, the usual workaround is to boot into the
>>>install CD and select the Update Drivers function from the Disk
>>>Setup. Unfortunately, since I have a late 2003 model that barely
>>>supports booting into Classic, the installation program is only
>>>capable of running from withing OS X's Classic Mode; it doesn't
>>>work when booted directly off the CD. The Tiger and Panther
>>>installation disks only seem to be capable of installing the
>>>drivers when partitioning the disk from scratch; they don't know
>>>how to fix the drivers without wiping the disk. So, no Update
>>>Drivers for me. The problem does not occur if Debian is installed
>>>without the yaboot Apple_Bootstrap partition, but then, of
>>>there's no way to boot Debian. Creating the Apple_Bootstrap
>>>partition with OpenBSD's pdisk rather than Debian's mac-fdisk
>>>doesn't help either, so I think the problem must occur when
>>>actually installs itself onto the Apple_Bootstrap partition.
>>>the disk and installing Mac OS X / Mac OS 9.2.2 from scratch will
>>>resolve the issue, but then of course it will break again when I
>>>install Debian again.
>> I notice that the bug report is rather recent, being filed
>> squeeze.
>> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=604134
>> I wonder if it would work properly if wiped the disk, and tried
>> again, but this time used squeeze with lenny's yaboot.
>> Charset: UTF8
>> Note: This signature can be verified at
>> Version: Hush 3.0
>> lYwmWJzxyLVZaQxQqv6tERoluZrJyvqSOAVodvc3JIs=
>> =Zurw
>> -----END PGP SIGNATURE-----
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org
> Archive:
Charset: UTF8
Version: Hush 3.0
Note: This signature can be verified at https://www.hushtools.com/verify


Reply to: