[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot update wheezy

On 03/27/2011 11:43 AM, Mark Fletcher wrote:
For over a week now I've been unable to upgrade wheezy. I do aptitude
update as root, which is fine, then also as root do aptitude
safe-upgrade. When I do that, it says "resolving dependencies" and the
open and closed statistics start going up. Right now open is at about
34000 and closed is at 29000. Defer is at 329 and conflict is at 62. It
just sits there with open and closed ticking steadily up, and never
seems to finish.

This doesn't feel right to me. I am not sure what else to post in the
way of info as aptitude doesn't even get to the stage of producing
interesting output before going into this endless-looking process if
ostensibly resolving dependencies. Could my system's notion of package
relationships have got messed up somehow, and if so how can I clean it
up? Any help appreciated.

Machine is self-built intel core i7 920 with 8Gb of Ram and an nVidia
GeForce 9800 GTX+ based graphics card. It's about 2 years old. I
originally installed squeeze which had recently gone into Testing at the
time, and upgraded using aptitude full-upgrade to wheezy shortly after
squeeze became stable. Since upgrading, for a few weeks, everything was
fine until about a week ago when I noticed I couldn't update as
described above. I left it for a week thinking it was a package
dependency prob that would fix itself eventually, but it doesn't seem to
be doing so.

Any help appreciated.



Give 'aptitude -f install' a try. Thats how I got it going, finally. Now the updates/upgrades work as usual.


Reply to: