[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IRQ 19 Problem in Squeeze & Wheezy but Sid OK



On 03/21/2011 01:56 PM, Mark Copper wrote:
On Mon, Mar 21, 2011 at 12:07 PM, Wayne Topa<linuxtwo@gmail.com>  wrote:
On 03/21/2011 10:49 AM, Mark Copper wrote:

On Sun, Mar 20, 2011 at 12:32 PM, Wayne Topa<linuxtwo@gmail.com>    wrote:

  Linux Version 2.6.32-5-amd64
  Compiled #1 SMP Wed Jan 12 03:40:32 UTC 2011
  Two 1GHz AMD Athlon 64 X2 Processors, 4GB RAM
  3999.52 Bogomips Total


I installed, back in February, Squeeze on 3 partitions. For 2 days
Squeeze worked fine with wicd but then quit with this error:

____

eb 22 12:13:10 dj kernel: [  604.383622] wlan0: authenticate with
00:21:e8:b5:c4:b5 (try 1)
Feb 22 12:13:10 dj kernel: [  604.580045] wlan0: authenticate with
00:21:e8:b5:c4:b5 (try 2)
Feb 22 12:13:10 dj kernel: [  604.780042] wlan0: authenticate with
00:21:e8:b5:c4:b5 (try 3)
Feb 22 12:13:10 dj kernel: [  604.953908] Pid: 0, comm: kworker/0:0 Not
tainted 2.6.37-1-amd64 #1
Feb 22 12:13:10 dj kernel: [  604.953910] Call Trace:
Feb 22 12:13:10 dj kernel: [  604.953912]<IRQ>      [<ffffffff81092ff1>] ?
__report_bad_irq+0x30/0x80
Feb 22 12:13:10 dj kernel: [  604.953923]  [<ffffffff81093168>] ?
note_interrupt+0x127/0x19f
Feb 22 12:13:10 dj kernel: [  604.953927]  [<ffffffff8100f6d5>] ?
sched_clock+0x5/0x8
Feb 22 12:13:10 dj kernel: [  604.953931]  [<ffffffff81093b47>] ?
handle_fasteoi_irq+0xcc/0xf7
Feb 22 12:13:10 dj kernel: [  604.953935]  [<ffffffff8100bf48>] ?
handle_irq+0x17/0x1f
Feb 22 12:13:10 dj kernel: [  604.953938]  [<ffffffff8100b603>] ?
do_IRQ+0x50/0xb5
Feb 22 12:13:10 dj kernel: [  604.953942]  [<ffffffff8131ef13>] ?
ret_from_intr+0x0/0x11
Feb 22 12:13:10 dj kernel: [  604.953944]<EOI>      [<ffffffff81028108>] ?
native_safe_halt+0x2/0x3
Feb 22 12:13:10 dj kernel: [  604.953951]  [<ffffffff81010a95>] ?
default_idle+0x39/0x57
Feb 22 12:13:10 dj kernel: [  604.953954]  [<ffffffff81010bac>] ?
c1e_idle+0xf9/0xfd
Feb 22 12:13:10 dj kernel: [  604.953957]  [<ffffffff81008be9>] ?
cpu_idle+0xb2/0x124
Feb 22 12:13:10 dj kernel: [  604.953960]  [<ffffffff81317db4>] ?
start_secondary+0x1e5/0x1eb
Feb 22 12:13:10 dj kernel: [  604.980023] wlan0: authentication with
00:21:e8:b5:c4:b5 timed out


Message from syslogd@dj at Tue Feb 22 12:13:10 2011 ...
dj kernel: [  604.953998] Disabling IRQ #19

I then upgraded the 2nd Squeeze partition to Testing/Wheezy and the same
error occurred as above.


<SNIP>

Hi Wayne,

You reported is problem on Feb 27, right?

The IRQ 19 problem I reported then seems to disappear when I boot my
machine with the "irqpoll" parameter.

At least it has been up for 15 days with its /proc/irq/19/spurious
looking like this:
count 58513
unhandled 2
last_unhandled 1208748848 ms

the last unhandled IRQ being nearly 14 days ago.

Mark


Thanks Mark. Good to know it is working for you at least.

Did you do an upgrade or anything else before trying the irqpoll?

The irqpoll didn't work here, sadly, so I am still looking for the cause of
the problem.


Hi Wayne,

No, adding the irqpoll param was absolutely the only change I made.

Having trouble with the same IRQ number may just be a coincidence
given the different hardware; my system assigns IRQ 19 to my hard
disks and some USB ports.  But still, that both problems should
originate from cpu idle...maybe I just don't understand the stack
trace.

From what I was able to glean from the net, these problems aren't
easily resolved and seem to be hardware related.  Do you have another
wireless card you could try?


No I don't but, if it was hardware then I would expect that my Sid partition, which I am using now, and my 5+ year old testing partition
would have the same error, which they don't.

4 partitions on the same drive and 2 are working and, 2 are not.

I just did an upgrade on the, wheezy/testing partition with the irq 19 problem. The kernel-image was upgraded to linux-image-2.6.32-5-amd 2.6.32-31. I had hopes that this would fix the problem. No Joy, the problem remains. Note that I have 2 wireless connections so I was upgradeing using the GSM Modem which is a PPP connection.

I tried to upgrade the Squeeze partition but the problem has esculated and neither interface works on it so no net access at all now on Squeeze.

Thanks again for the post Mark.
Have a Nice Day

Wayne


Reply to: