[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IRQ 19 Problem in Squeeze & Wheezy but Sid OK (Partial-Success)

On 03/21/2011 07:29 PM, Wayne Topa wrote:
On 03/21/2011 05:34 PM, Mark Copper wrote:
On Mon, Mar 21, 2011 at 4:02 PM, Wayne Topa<linuxtwo@gmail.com> wrote:
On 03/21/2011 04:04 PM, Mark Copper wrote:

On Mon, Mar 21, 2011 at 1:49 PM, Wayne Topa<linuxtwo@gmail.com> wrote:

On 03/21/2011 01:56 PM, Mark Copper wrote:

On Mon, Mar 21, 2011 at 12:07 PM, Wayne Topa<linuxtwo@gmail.com>

On 03/21/2011 10:49 AM, Mark Copper wrote:

On Sun, Mar 20, 2011 at 12:32 PM, Wayne Topa<linuxtwo@gmail.com>

Linux Version 2.6.32-5-amd64
Compiled #1 SMP Wed Jan 12 03:40:32 UTC 2011
Two 1GHz AMD Athlon 64 X2 Processors, 4GB RAM
3999.52 Bogomips Total

Hi Wayne,

You reported is problem on Feb 27, right?

The IRQ 19 problem I reported then seems to disappear when I
boot my
machine with the "irqpoll" parameter.

At least it has been up for 15 days with its /proc/irq/19/spurious
looking like this:
count 58513
unhandled 2
last_unhandled 1208748848 ms

the last unhandled IRQ being nearly 14 days ago.


Thanks Mark. Good to know it is working for you at least.

Did you do an upgrade or anything else before trying the irqpoll?

The irqpoll didn't work here, sadly, so I am still looking for the
the problem.

Hi Wayne,

No, adding the irqpoll param was absolutely the only change I made.

Having trouble with the same IRQ number may just be a coincidence
given the different hardware; my system assigns IRQ 19 to my hard
disks and some USB ports. But still, that both problems should
originate from cpu idle...maybe I just don't understand the stack

From what I was able to glean from the net, these problems aren't

easily resolved and seem to be hardware related. Do you have another
wireless card you could try?

No I don't but, if it was hardware then I would expect that my Sid
partition, which I am using now, and my 5+ year old testing partition
would have the same error, which they don't.

4 partitions on the same drive and 2 are working and, 2 are not.

I just did an upgrade on the, wheezy/testing partition with the irq 19
problem. The kernel-image was upgraded to linux-image-2.6.32-5-amd
2.6.32-31. I had hopes that this would fix the problem. No Joy, the
problem remains. Note that I have 2 wireless connections so I was
upgradeing using the GSM Modem which is a PPP connection.

I tried to upgrade the Squeeze partition but the problem has esculated
neither interface works on it so no net access at all now on Squeeze.

Hi Wayne,

Not to be a bother, but you did check out driver issues, right? The
kernel is complaining, but the problem is communication with a device.
I have seen cases where a driver change is made in unstable before
stable. I needed stable and backported the driver. Worked for me.


No I didn't. The reason is that the drivers for both interfaces is built
into the kernel. Hence my thought that it is a kernel error, somehow.
how that happened is the mystery

Thanks for the thought though.

That's right. You may have to compile a custom kernel in order to
backport a driver--not something I personally like to do without a
reasonable chance of success---which is why you'd check the change
file on the source code for the driver or such like.

I have the source for the kernel and may just try that. ISTR that
Squeeze of Wheezy would not load the module for hddtemp. While all the
others can. I have noted that and will look into it.



I am putting this back on DU.

Thanks to your thought provoking questions I now have my wheezy
partition connecting to the net via wicd again. The internal
WiFi card, a D-Link DWA-556 that uses the ath9k kernel module, is still
not working not but I remembered that I had a NetGear WG111v2 usb dongle
and it uses the rtl8187 kernel module.

I reconfigured wicd to use the dongle and I am up and running on wheezy
with both Wifi adapters again.

This did not help with the Squeeze partition though. Although there are
no bugs listed for wicd on Squeeze, shortly after the lenny-> Squeeze
update, a bug was reported on the wicd version in testing and
Sid and it has be upgraded to 1.7.0+ds1-6. Stable is 1.7.0+ds1-5 so that
may be the problem there.

So I have 3 running now and can live with that.

Many thanks Mark. You jogged this Old Man's memory and I really
appreciate it.

Best Regards


Reply to: