[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: weired problem around grub2


Camaleón wrote:
> On Sun, 06 Feb 2011 06:35:50 +0100, Geronimo wrote:
> (...)
> > The point is - the new system should be deleted - I want to install
> > windows to that partition. So I need to install grub2 on my restored
> > root partition. But whatever I try - grub will not work with that
> > partition.
> (...)
> Maybe you can look into Rescatux (SuperGrubDisk) and try to install GRUB2
> from there. At least with GRUB Legacy, SGD always worked fine for me.

Thank you for that hint.

I tried that CD, but the result did not differ from my manual tries.
The point is, I have an external SATA-controller and disks change order too 
much times. That means, I don't have reliable device order.

So I put a label on each vital partition and mount them by using the label in 
fstab. Works fine so far.

What definitely does not work, is grub recognizing certain disk/partition. 
Although theres a device.map (with right identifiers for each drive), grub seem 
to not use it at all. Otherwise I don't understand current behaviour:

Boot-drive is the first drive connected to internal controller (MB). The 
external controller has 3 drives connected, which means, boot-drive changes 
between sda and sdd.
Boot-drive is configured to be the first drive (at BIOS bootdrive order).

When I use the new install-CD of debian stable and boot into rescue-64bit, the 
root partition appears in the list as sda1 - so I select to start a 
commandline on that root partition. 
In that session, a df shows, that the root-partition is now sdd1 - so two 
different applications have different view to drives on the same run.

Extremely strange ;)

That boot-drive has 2 partitions, both containing debian squeeze with fstype 
ext4. The first partition is a restored image, which originated from an ext3 
installation, the second partition is a fresh installation using ext4.
Both installations are up-to-date.

When I start with the rescue-mode from install-CD and open a session to 
partition2, I can install grub with "grub-install" and the system will be 
Doing the same with partition 1 - grub-install says "no errors" but on reboot 
grub hangs and is not able to start the menue - so the system is unbootable.

I already tried to reinstall grub on partition 1 - but did not change 
anything. Is the boot-directory expected to be located on certain block, or 
what could be the reason of such a weired behavior?

kind regards


Reply to: