[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: weired problem around grub2

On Mon, 07 Feb 2011 07:53:56 +0100, Geronimo wrote:

> Camaleón wrote:

>> Maybe you can look into Rescatux (SuperGrubDisk) and try to install
>> GRUB2 from there. At least with GRUB Legacy, SGD always worked fine for
>> me.
> Thank you for that hint.
> I tried that CD, but the result did not differ from my manual tries. The
> point is, I have an external SATA-controller and disks change order too
> much times. That means, I don't have reliable device order.

"Installing GRUB" and "booting from GRUB" are two separate things :-)

If you are experiencing problems with "booting", it is important to note 
the error you are getting (black screen, just cursor, reach the menu with 
error ouputs...).

If you are having problems with "installing" it, that's a different 
issue, more severe, I'd say.

> So I put a label on each vital partition and mount them by using the
> label in fstab. Works fine so far.

Better that labels are UUID (Debian recommended) or ID for identifying 

> What definitely does not work, is grub recognizing certain
> disk/partition. Although theres a device.map (with right identifiers for
> each drive), grub seem to not use it at all. Otherwise I don't
> understand current behaviour:
> Boot-drive is the first drive connected to internal controller (MB). The
> external controller has 3 drives connected, which means, boot-drive
> changes between sda and sdd.
> Boot-drive is configured to be the first drive (at BIOS bootdrive
> order).
> When I use the new install-CD of debian stable and boot into
> rescue-64bit, the root partition appears in the list as sda1 - so I
> select to start a commandline on that root partition.
> In that session, a df shows, that the root-partition is now sdd1 - so
> two different applications have different view to drives on the same
> run.
> Extremely strange ;)

I've also found a similar behaviour with GRUB Legacy and a USB connected 
hard disk: GRUB saw the external unit in a different "order" when running 
directly from the GRUB console and once the system has booted.
> That boot-drive has 2 partitions, both containing debian squeeze with
> fstype ext4. The first partition is a restored image, which originated
> from an ext3 installation, the second partition is a fresh installation
> using ext4. Both installations are up-to-date.
> When I start with the rescue-mode from install-CD and open a session to
> partition2, I can install grub with "grub-install" and the system will
> be bootable.
> Doing the same with partition 1 - grub-install says "no errors" but on
> reboot grub hangs and is not able to start the menue - so the system is
> unbootable.

Did you mark the old partition with the "bootable" flag?

> I already tried to reinstall grub on partition 1 - but did not change
> anything. Is the boot-directory expected to be located on certain block,
> or what could be the reason of such a weired behavior?

Dunno :-?

I would first ensure your GRUB2 is correctly installed in the old 
partition but provided "grub-install" gives no warning nor error, I'd 
expect it is so.



Reply to: