[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot mount floppy drive in Squeeze

On 07/12/10 14:38, Dom wrote:
On 06/12/10 11:46, Dom wrote:
On 06/12/10 11:34, Camaleón wrote:
On Sun, 05 Dec 2010 16:27:48 -0500, Stephen Powell wrote:

On Sun, 05 Dec 2010 16:09:52 -0500 (EST), Camaleón wrote:
On Sun, 05 Dec 2010 15:07:20 -0500, Stephen Powell wrote:
Well, I'm not exactly a newbie. I've been using Linux for more than
10 years. But I must be doing something wrong. I can't seem to get a
floppy disk to mount.
Weird :-?

I would try with the simplest command:

mount /dev/fd0 /mnt

If you get no error, run "mount" to ensure your floppy has been
mounted. Also, check for "dmesg" output.
No dice. I tried your suggested command, except that I changed /dev/fd0
to /dev/fd1, since I need the 5.25-inch drive, not the 3.5-inch drive,
but other than that it was just as you suggested. No mount, no error
message. The only output from dmesg is the original warning message:

FAT: utf8 is not a recommended IO charset for FAT filesystems,
filesystem will be case sensitive!

which also comes out on the terminal, since I am issuing the command
from an active Linux virtual console, not a terminal emulation
window in
Strange, indeed.

I would try to load the floppies in another computer, maybe they become
damaged somehow :-?

Also, to discard any problem with squeeze, you can test it under a
(by instance, in lenny, I don't get that "warning" about utf-8 charset
when accessing my floppy disks).


I recently hit the same problem, but assumed it was just my system
playing up.

Using a USB floppy drive, I created a FAT floppy from an image file,
but when I wanted to change some files on it, it wouldn't mount.

Copying the floppy to a file using dd, then mounting with loop option

There were no read or write errors during any of these processes (except
on one bad floppy I tried).

I found the same problem with an ext2 formatted floppy. mount -v -t ext2
/dev/sdb /media/floppy returns success, but nothing is mounted.

I just tried partitioning the floppy with cfdisk, then creating an ext2
filesystem on /dev/sdb1. This mounted without a problem.

I suspect this is a bug.


Following up to myself, after further testing.

I only get this behaviour on one of my systems, all the others seem to
handle mounting floppies fine.

With a little bit of investigation, and the aid of strace, I now believe
that the mount command *is* working correctly and mounting the floppy -
then, almost instantly, something is unmounting it again.

At first I thought it might be because my laptop has Gnome installed and
the other machine I tested it on didn't, but I have since tried on
another system with Gnome and that one is fine too.

I shall keep investigating and maybe try cloning my laptop onto another
machine with a non-USB drive.


Found the culprit. It's udisks-daemon and appears to be this bug:
"udisks prevents mounting of floppy disks".

Killing the udisks-daemon enabled mounting of the drive.

However, I suspect this is a different problem to the one the OP is getting, as this only affects USB floppy drives, not "normal" ones.


Reply to: